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About This Release 
This document describes the enhancements for ERDAS IMAGINE 2020 (v16.6.0), including IMAGINE 
Photogrammetry (formerly LPS Core) and ERDAS ER Mapper. Although the information in this document is 
current as of the product release, see the Hexagon Geospatial Support website for the most current version.  

This release includes both enhancements and fixes. For information on fixes that were made to ERDAS 
IMAGINE for this release, see the Issues Resolved section. 

This document is only an overview and does not provide all the details about the product's capabilities. See 
the online help and other documents provided with ERDAS IMAGINE for more information. 

Development of ERDAS IMAGINE 2020 focussed on ensuring that virtually all aspects of ERDAS IMAGINE 
run in 64-bit. Consequently, the installer has been split into three separate installers: ERDAS IMAGINE 2020 
64-bit; ERDAS IMAGINE 2020 32-bit; and ERDAS ER Mapper 2020. 

In addition, there are new Operators, such as the Compute Grey-Level Co-Occurrence Matrix operator, as well 
as numerous software quality improvements. 

 

ERDAS IMAGINE Product Tiers 
ERDAS IMAGINE® performs advanced remote sensing analysis and spatial modeling to create new 
information. In addition, with ERDAS IMAGINE, you can visualize your results in 2D, 3D, movies, and on 
cartographic-quality map compositions. The core of the ERDAS IMAGINE product suite is engineered to scale 
with your geospatial data production needs. Optional modules (add-ons) providing specialized functionalities 
are also available to enhance your productivity and capabilities. 

IMAGINE Essentials® is the entry-level image processing product for map creation and simple feature 
collection tools. IMAGINE Essentials enables serial batch processing. 

IMAGINE Advantage® enables advanced spectral processing, image registration, mosaicking and image 
analysis, and change detection capabilities. IMAGINE Advantage enables parallel batch processing for 
accelerated output. 

IMAGINE Professional® includes a production toolset for advanced spectral, hyperspectral, and radar 
processing, and spatial modeling. Includes ERDAS ER Mapper. 

IMAGINE Photogrammetry maximizes productivity with state-of-the-art photogrammetric satellite and aerial 
image processing algorithms. 
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New Platforms 

Full 64-bit Installer 

On modern 64-bit computers, being able to run as a true 64-bit application allows full exploitation of the 
computer’s resources, including addressing more than 4GB of memory. 

Over the previous few releases Hexagon has been moving more and more ERDAS IMAGINE executables to 
run 64-bit. With each such release a few non-GUI applications (jobs) were made available in both 32-bit and 
64-bit and the user was able to configure which one was run by the Session Manager. In ERDAS IMAGINE 
2018 we released the main Ribbon GUI (ewkspace.exe) in both 32-bit and 64-bit, but whether applications 
launched from either of these configurations ran as 32-bit or 64-bit (if available) was still variable, depending 
on the 64-bit configuration settings. This mixed approach presented some problems, not least the lack of 
transparency to the user as to whether the job they were about to execute would run 32-bit or 64-bit.   

Consequently, ERDAS IMAGINE 2020 has been clearly split into two separate installers (plus a third one for 
ERDAS ER Mapper): One in which the entire suite runs as 32-bit applications and one in which the entire suite 
runs as 64-bit. This means that if someone starts ERDAS IMAGINE 2020 64-bit they can be sure that any 
feature they utilize will be running 64-bit and is therefore capable of exploiting larger amounts of system 
memory and other resources.  

This split also makes any configuration tasks much more straightforward. If you want to use Python with 
ERDAS IMAGINE 2020 32-bit, then you need a 32-bit version of Python. If you want to configure CSM/MSP to 
work with ERDAS IMAGINE 2020 64-bit, then you just need 64-bit CSM/MSP, etc. 

Note that all three installers (ERDAS IMAGINE 2020 64-bit, ERDAS IMAGINE 2020 32-bit, and ERDAS ER 
Mapper 2020) can be installed on a single computer if needed.  

If 64-bit is so great, why do we still have ERDAS IMAGINE 2020 32-bit? Unfortunately, not every program 
could be ported to 64-bit, usually because there was a dependency on a third-party component that is only 
made available in 32-bit. These occurrences are very limited compared to the number of programs that have 
been successfully included into ERDAS IMAGINE 2020 64-bit. However, there is a possibility that a production 
workflow is depending on one of these capabilities and so ERDAS IMAGINE 2020 32-bit is being provided so 
that customers who need these capabilities can continue to use them if needed. 

The functionality that is only available in ERDAS IMAGINE 2020 32-bit is as follows: 

• Image Equalizer 

• Image Catalog 

• StereoSAR DEM 

• IMAGIZER 

• External Projections 

• Surfacing Tool (deprecated in favour of Terrain Prep tool) 

• ESRI Grid support 

• MultiGen OpenFlight format support 

• Oracle Geospatial Raster support 

• ArcSDE support 

• TerraModel TIN support 

• IRS Sensor Model 

• MapInfo support 

• Geodatabase support 

Depending on component availability, some of these capabilities may find their way back into a 64-bit version 
of ERDAS IMAGINE in the future.  
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ArcGIS 10.7 

ERDAS IMAGINE 2020 (32-bit) has been tested and declared Supported when using an installed and licensed 
version of ArcGIS 10.6, 10.6.1 and 10.7 in order to provide Geodatabase support libraries.  

Alternatively, the IMAGINE Geodatabase Support component (based on ArcGIS Engine 10.7) can be installed 
to provide Geodatabase support. 

Please note that at this time ArcGIS 10.7.1 is not supported. 

New Licensing 

ERDAS IMAGINE 2020 is delivered with version 16.6.9.110 of the Hexagon Geospatial Licensing 2020 tools. 
However, if there is a newer version available for download it is strongly recommended that customers 
upgrade to the newer version. The appropriate download can be found on the Downloads section of the 
Hexagon Geospatial web site: 

https://download.hexagongeospatial.com/search?lang=en&product=b3b4786d3d4742ae8d1e7aeee50dae69 

Since Hexagon Geospatial Licensing 2020 v16.6.9.110 is integrated into the ERDAS IMAGINE 2020 installer, 
any computer where you install will have any existing installation of Hexagon Geospatial Licensing 
automatically updated to v16.6.9.110. If in doubt, refer to Windows’ Add or Remove Programs utility to 
determine the currently installed version. 

 

New Technology 

New Operators for Spatial Modeler  

Hexagon has continued to add new operators to Spatial Modeler. New (or modified) operators with a brief 
description of their capabilities are described below. See the ERDAS IMAGINE 2020 Help for full details of 
each operator, as well as the Hexagon Geospatial Community > Spatial Recipes page, for examples of Spatial 
Models that use many of these capabilities. 

Classify Buildings 

 

The operator identifies points from the input point cloud that fall on buildings and reassigns them to the 
Building class (Class 6). The operator requires that the points that fall on the ground in the point cloud have 
already been classified, that is, assigned to the Ground class (Class 2). If the ground points in the input point 
cloud are not classified, you can classify them using the Classify Ground operator. 

The classification is performed by analyzing the geometric relationship of the non-ground points to their 
neighbors, looking for planar areas above ground that satisfy the specified height and area criteria. 

https://download.hexagongeospatial.com/search?lang=en&product=b3b4786d3d4742ae8d1e7aeee50dae69
https://community.hexagongeospatial.com/t5/Spatial-Recipes/tkb-p/KS_SpatialModeler_AnalyticalRecipes
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Extract Building Footprints 

 

The operator extracts building footprints based on points in the point cloud that have already been classified 
as Building points (Class 6). The operator requires that the points in the point cloud that fall on the ground and 
on buildings have already been classified to the Ground class (Class 2) and the Building class (Class 6) 
respectively. 

Compute Ground Sampling Distance 

 

This operator computes the ground sampling distance for a point cloud by analysing the distance between 
adjacent points. By default, the first 1000 points having last and single returns are included in the computation. 
You may override this by putting data on the SelectionCriteria port. Typically, the output from this operator is 
used to specify the cell size when converting from point cloud to raster. 

Calculate Cell Size 

 

This operator calculates appropriate ground-space pixel dimensions for an input grid or image that is to be 
resampled. This is most frequently required if the input grid is a referenceable grid to be orthorectified (such as 
a NITF image with embedded RPCs), or if the input grid is to be reprojected to a different CRS. 

The algorithm used has also been integrated into standard ERDAS IMAGINE resample dialogs so that the 
default pixel size populated into the dialogs should attempt to retain the optimal level of precision (without 
over-sampling). 
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Grow Features 

 

Grow features operator extracts features from raster data and seed pixel(s) by growing the seed pixel(s) into 
larger regions. Regions are grown by adding neighbouring pixels that are spectrally similar to the seed 
pixel(s). Each neighbour pixel is evaluated to measure if it is spectrally similar to the seed and, if it is, it is 
incorporated into the region. The enlarged region then has new neighbours to be evaluated. This process 
continues until no new neighbours are added to the region being grown (or one of the other growing 
constraints is met). 

The improved region growing algorithm has also been integrated into the 2D Views vector editing tools: 
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Initialize CART Regressor 

 

This operator defines and trains a CART regressor that is used as an input for estimating data using the 
Regression Using Machine Learning operator.  

Initialize Random Forest Regressor 

 

This operator defines and trains a Random Forest regressor that is used as an input for estimating data using 
the Regression Using Machine Learning operator.  

Predict Using Machine Learning 

 

This operator performs regression on the input data using the trained regressor specified on the 
MachineIntellect port. The input data can be of type IMAGINE.Features or IMAGINE.Raster. 

Augment Training Data 
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This operator creates additional training data for Classify Using Deep Learning by modifying existing training 
data. Depending on the selected options, it will produce rotated, scaled, translated and flipped versions of the 
input training data. 

Assess Object Detection Accuracy 

 

Object detection accuracy assessment is a process in which the result from object detection is compared to 
ground truth data to measure the agreement between the two. This operator performs accuracy assessment 
by comparing the rectangular bounding box and class attribute of the objects that represent the ground truth 
with the objects detected from the object detection. 

Densify Geometry 

 

Densify Geometry operator adds vertices to the geometry of the input features using a maximum distance 
factor. If the distance between two vertices is larger than MaxDistance, a new vertex is inserted halfway 
between the two vertices. This repeats until no segment between vertices is larger than MaxDistance, or until 
the output geometry exceeds the size of MaxSize. 

Smooth Geometry 

 

Smooth Geometry operator smooths the geometry of the input features using a weighted-average smoothing 
algorithm. Smoothing shifts the position of points on a geometry in order to remove small perturbations and 
capture only the most significant trends. Unlike simplification, smoothing preserves the number of points in a 
geometry but improves their appearance. The operator offers control over the algorithm through a 
densification tolerance, look-ahead count, and weighting factor. 
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Arrange Items 

 

Selects, arranges, and duplicates values from a list or table given the order specified on the RangeList port, to 
create an output list or table. 

Examples: 

Given DataIn [ -2 , 0 , 2 , 3 , 7 , 8 ] and RangeList [ 0 , 1 , 3 , 0 , 3 , 5 ], DataOut results in [ -2 , 0 , 3 , -2 , 3 , 8 ] 

Given DataIn [ -2 , 0 , 2 , 3 , 7 , 8 ] and RangeList [ 0:2 , 1:4 ], DataOut results in [ -2 , 0 , 2 , 0 , 2 , 3 , 7 ] 

This operator is often used in conjunction with the output created by the Sort Items operator so that a set of 
values can be ordered in the same manner as another set of values. For example, consider two Tables, one 
consisting of Class Names and another consisting of the Histogram values associated with those Class 
Names. If the Class Names Table is sorted alphanumerically, the Table of Histogram values could be re-
organized so that the Histogram values are still ordered correctly against their corresponding Class Names by 
using the Indices output by Sort Items as the RangeList input to this operator. 

 

Catch Error 

 

This operator transforms the condition of whether an error occurs in the execution of the contained submodel 
into a boolean result.  

This operator can be useful, for example, in allowing an iterative submodel to execute to completion over a 
collection of dataset references of uncertain applicability. If the submodel illustrated below were placed into an 
Iterator fed by a Multi Filename Input operator result, any file names that were not appropriate for the Raster 
Input operator contained in the Catch Error submodel would end up in the BadFilenameOut list. 
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Contents of an Iterator operator using Catch Error: 

 

 

 

Catch Error submodel: 

 

 

Color Input 

 

Creates a Color. Double-click the operator to open its configuration dialog. The Color Chooser opens. The 
Color to be output is placed on the Input port, which is hidden by default. 

Combine 

 

Combines multiple lists into a single list. A new List/Table is created consisting of each element of the 
Lists/Tables provided, in the order provided (Collection1's element will be followed by Collection2's element, 
etc.). This is an expandable operator, so you can add as many Collection ports as required. 

The model below shows how to Combine two Tables together. 
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Compute GLCM Texture 

 

Computes a texture feature for an input image. The specified texture feature is computed from various 
statistical properties of a per-pixel internally generated gray-level co-occurrence matrix (GLCM). 

Texture Computations using a Grey-Level Co-Occurrence Matrix are usually considered to be "second order" 
measures of texture present in the original image. Traditional texture measures are usually considered "first 
order" since the texture measures are statistics calculated from the original image values, like variance, and 
do not consider pixel neighbor relationships. Conversely "second order" measures consider the relationship 
between groups of two (usually neighboring) pixels in the original image. 

Such texture measures are considered highly useful as derived information for input into other processes such 
as image classification, especially Machine Learning, and other purposes, such as to identify built-up areas in 
the example below:  
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Note that GLCM calculations are highly compute intensive and so benefit from the presence of a GPU-enabled 
graphics card running OpenCL. 
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Create Dice Boundaries 

 

Create Dice Boundaries splits up the boundary of an image into smaller, regularly sized and spaced 
boundaries that can be used for subsetting. Neighboring new boundaries can overlap each other by an extent 
specified by the XOverlap and YOverlap ports. 

The example Spatial Model shown below uses the Create Dice Boundaries operator to create a regular grid of 
area polygon geometries over an image, which could then be used for Zonal Change Detection or Deep 
Learning feature extraction. 
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Create Image Pyramid 

 

This operator ensures the existence of an image pyramid and statistics for an image dataset. 

It produces or verifies the existence of a persistent, optimal sequence of images, each of which is 
progressively lower in resolution than the preceding image in the sequence. The primary use of an image 
pyramid is to increase rendering speed and reduce aliasing artifacts when visualizing the image at scales 
larger than its original resolution. 

If you want to ensure that all image pyramids are of the type (Generator) and are created using the 
downsampling method specified or you want to force new image pyramids to be created, use the Delete 
Image Pyramid operator ahead of this operator. 

It also ensures that image statistics are available for the image. This occurs even if a suitable image pyramid 
is already present. 

One major advantage of this new mode of generating pyramid levels is the ability to create PYRX format 
pyramid files. These use ECW compression and consequently are not only fast but also take up far less disk 
space than traditional pyramid file formats.  

In the example below, the original satellite image was 713MB in size. Three different formats of pyramid file 
were generated and the image displayed Fit to Frame. The PYRX pyramid file is 1/10th the size of the other 
two formats while maintaining display quality. 

 

Please note that Create Image Pyramid replaces all the functionality formerly provided by Create RSETs. 
Create RSETs should no longer be used. 
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The new modes of generating pyramid files have also been built into the Raster Output operator, Image 
Commands tool (Home tab > Information group > Metadata pulldown > Edit Image Metadata) for batch 
creation of pyramids, the Image Metadata dialog (Home tab > Information group > Metadata pulldown > 
View/Edit Image Metadata), as well as any application that uses Spatial Modeler for performing its processing. 
The type of Generator used by default, as well as the associated downsampling technique, can be controlled 
via Preferences. 

Note: if routinely running ERDAS IMAGINE 2020 32-bit (as opposed to the 64-bit version) you may encounter 
errors regarding insufficient memory when processes attempt to create .pyrx formatted pyramid files for larger 
image files. If this occurs there are two possible workarounds (other than running ERDAS IMAGINE 2020 64-
bit): 

• In the Preference Editor (File > Preferences) reduce the amount of memory allowed for the Spatial 
Modeler to run by changing Percentage of Available Memory to Consume to a lower value (such as 
30%). This allows the ECW/JP2 Encoding engine more memory to perform the compression 

• Or, alter the Pyramid Layer Generator preference from the default setting to “Always use the RRD 
Pyramid Generator”. This effectively sets the software to produce pyramid files in the manner it did 
prior to the 2020 release. 

Delete Image Pyramid 

 

Delete Image Pyramid deletes existing image pyramid from a raster image.  

All image pyramids that are discovered will be deleted (if possible). This includes: 

• ERDAS Reduced Resolution Dataset (*.rrd) 

• Extended compressed image pyramid (*.pyrx) 

• NITF RSET 

• Minifiles 

• GDAL Overviews (*.ovr) 

Pyramids that cannot be deleted include: 

• Pyramids internal to IMAGINE Image (*.img) 

• Pyramids from Wavelet Compression (*.ecw, *.jp2, *.sid) 

Enhance Contrast Using CLAHE 
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Contrast Limited Adaptive Histogram Equalization (CLAHE) algorithm is a technique used to enhance contrast 
in images. Traditional Histogram Equalization uses a single transformation derived from the image histogram 
to transform all pixels. As such it is difficult to derive a single transformation that can balance the contrast in 
dark, light and mid-tone areas of the histogram, especially when the data being displayed has a dynamic 
range larger than 8-bit (and the rendering software or display device only supports 8-bits per color channel). 

So techniques such as CLAHE were developed to spatially adapt the transformation and reveal the detail in 
dark and bright areas of a raster while maintaining contrast in mid-tone areas. For example, CLAHE can 
enhance hidden detail in the shadows cast by large buildings, clouds, etc. In these locations the pixel DN 
values will be low, but for sensors with 10, 11, 12-bit or greater dynamic ranges there may still be a wide range 
of values present, but the global look-up table used to render the image to an 8-bit per color channel display 
bins all those shadow areas into a few dark bins (i.e., low visual contrast). The spatially adaptive nature of 
CLAHE allows the inherent contrast in these shadow areas to be broadened and brightened to balance with 
neighboring non-shadow areas. 

For example, here’s a 12-bit color image with both bright areas and dark shadows that with a standard LUT 
shows little detail in the shadows: 

 

 

The screenshot below shows the result of using the Enhance Contrast Using CLAHE operator with a Contrast 
Retention Factor of 0.2: 
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As can be seen, contrast is enhanced in the shadow areas without saturating the already bright areas. 

Get TIFF Options 

 

Creates the format specific output option dictionary for Tagged Image File Format (TIFF), which can then be 
fed to the Raster Output operator to control format-specific output parameters, such as wanting BigTIFF 
format, an alpha channel persisted, data compression, etc.  

Resize Matrix 
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The purpose of this operator is to take an existing Matrix and alter the dimensions of that Matrix by either 
removing rows and/or columns or adding new rows and/or columns (or any combination thereof). If adding 
new rows and/or columns, the values to be used in those new cells can be specified. If removing rows, they 
are removed from the bottom of MatrixIn, and if removing columns, they are removed from the right side of 
MatrixIn. Similarly, if adding rows, they are added to the bottom of MatrixIn, and if adding columns, they are 
added the right side of MatrixIn. 

If extending MatrixIn in one dimension only (either rows or columns), you may supply a Matrix for 
InitialValues. If extending the number of rows, the Matrix provided for InitialValues must have the same 
number of columns as MatrixIn. It may have either a single row or as many rows as are being added to the 
Matrix. If it contains a single row, all rows being added to the Matrix are filled with the single row. If extending 
the number of columns, the Matrix provided for InitialValues must have the same number of rows as 
MatrixIn. It may have either a single column or as many columns as are being added to the Matrix. If it 
contains a single column, all columns being added to the Matrix are filled with the single column. 

Examples using a MatrixIn with five rows and nine columns: 

 

• Setting NumRows of 8 and NumColumns of 14 will extend the Matrix by three rows and five columns and set 
the new cells to InitialValues, which must be a Scalar. If InitialValues is -1, MatrixOut would be  

 

 

• If InitialValues is a Matrix with one row and nine columns, 
 

 
 
column 0 of the added rows will be set to the value in cell 0,0 in the InitialValues Matrix, column 1 of the added 
rows will be set to the value in cell 0,1 in the InitialValues Matrix, etc. MatrixOut would be 
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• If InitialValues is a Matrix with three rows and nine columns, 

 
 
the first added row will be set to the values in row 0 of the InitialValues Matrix, the second added row will be set 
to the values in row 1 of the InitialValues Matrix, and the third added row will be set to the values in row 2 of the 
InitialValues Matrix. MatrixOut would be  
 
 

 

Resize Table 

 

Adjusts the number of rows in a Table (up or down). The InitialValues port takes a Table as input and so this 
operator can be used to append Tables together. 

Set Matrix Values 

 

The purpose of this operator is to take an existing Matrix and modify specific cells of that Matrix with user-
specified values. 

If only RowRangeList or ColumnRangeList is provided (the cells in all columns of one or more rows or all 
rows of one or more columns are being set), you may supply a Matrix for Values. If only RowRangeList is 
provided, the Matrix provided for Values must have the same number of columns as MatrixIn. It may have 
either a single row or as many rows as are specified in RowRangeList. If it contains a single row, all rows 
specified in RowRangeList will be filled with the single row. If only ColumnRangeList is provided, the Matrix 
provided for Values must have the same number of rows as MatrixIn. It may have either a single column or 



 

4 October 2019  24 

as many columns as are specified in ColumnRangeList. If it contains a single column, all columns in 
ColumnRangeList will be filled with the single column. 

Note that both RowRangeList and ColumnRangeList are 0-based indices. I.e. the first row is row 0, the 
second row is row 1, etc. 

Examples using a MatrixIn with five rows and nine columns:  

 

 

• Setting a RowRangeList of 1:1,3:4 (three rows) and ColumnRangeList of 2:4 (three columns), will set the cells 
at 1,2, 3,3, and 4,4 to Values, which must be a Scalar. If Values is -1, MatrixOut would be 

 
 

• RowRangeList of 2:4 with no ColumnRangeList will set all cells in rows 2, 3, and 4 to Values. Values may be 
either a Scalar, a Matrix with one row and nine columns, or a Matrix with three rows and nine columns. 

 
If Values is a Scalar, all cells in rows 2, 3, and 4 will be set to that value. If Values is -1, MatrixOut would be 
 

 
 

• If Values is a Matrix with one row and nine columns, 
 

 
 
column 0 of rows 2, 3, and 4 will be set to the value in cell 0,0 in the Values Matrix, column 1 of rows 2, 3, and 4 
will be set to the value in cell 0,1 in the Values Matrix, etc. MatrixOut would be 
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• If Values is a Matrix with three rows and nine columns, 
 

 
 
row 2 will be set to the values in row 0 of the Values Matrix, row 3 will be set to the values in row 1 of the Values 
Matrix, and row 4 will be set to the values in row 2 of the Values Matrix. MatrixOut would be 
 

 
 

Set Table Values 

 

Set Table Values sets the values of specified rows in a Table.  

If the same row number is specified multiple times in RangeList, the value of that row in the Table will be set 
each time. That means that if Values is a Table, the value of that row in TableOut will be what it was set to 
the last time that row was specified in RangeList. For example, if TableIn is [83,208,180,96,45,234], 
RangeList is [1:3,1:1] and Values is [34,27,160,69], TableOut will be [83,69,27,160,45,234]. 

Sort Items 

 
Takes a List or Table and creates a List or Table of values and a List of indices (0-based), which are sorted via 
the specified Order (Ascending/Descending). 

For example: 

• Ascending order. Given DataIn [ 15,12,17,13 ], DataOut is [ 12,13,15,17 ] and Indices is [ 1,3,0,2 ]  

• Descending order. Given DataIn [ 15,12,17,13 ], DataOut is [ 17,15,13,12 ] and Indices is [ 2,0,3,1 ]. 

The output Indices are used in conjunction with the Arrange Items operator so that a set of values can be 
ordered in the same manner as another set of values. For example, consider two Tables, one consisting of 
Class Names and another consisting of the Histogram values associated with those Class Names. If the Class 
Names Table is sorted alphanumerically, the Table of Histogram values could be re-organized so that the 
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Histogram values are still ordered correctly against their corresponding Class Names by using the Indices 
output by this operator as the RangeList input to the Arrange Items operator. 

Update Image with RPCs 

 

Some image format readers do not automatically recognize the associated Rational Polynomial Coefficient 
(RPC) information. In this case, the user must manually geometrically calibrate (update) the RPC information 
to the image so that ERDAS IMAGINE can use that information to accurately georeference the data. This 
operator uses the RasterFilename and SensorModelName to locate and use an RPC file to update the image. 

The optional RPCFilename is offered as an input in case the operator fails to automatically locate the file. 

 

Updated Operators 

Classify Using Machine Learning 

 

A new output port called TrainingAttributeImportances has been added. When the operator is run, this port 
produces a dictionary containing the names of the attributes used for classification and their associated 
importance to the classification. These values range from 0 to 1 and the summed importance of all training 
attributes is defined to be 1. If MachineIntellect does not support this output measure, all importances are 
equal to 1/<number of training attributes>. 

The importance values can be extremely useful in identifying the most important input variables contributing to 
successful classifications (and perhaps more importantly in identifying the unimportant variables so they can 
be excluded from later classifications, making the classification process more efficient). 
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Initialize Naïve Bayes 

 

This operator defines and trains a Naive Bayes classifier that is used as an input for classifying data using the 
Classify Using Machine Learning operator. 

A new input port called TrainingAttributesScaling can be used to scale the training attribute values to a similar 
range. Scaling may improve training speed and classification accuracy. 

Orthorectify 

 

Data in a raster stream may be georeferenceable rather than being georectified (in older parlance, the data is 
geometrically calibrated with a 2D or 3D geometric model as opposed to being rectified to a projected 
coordinate system). Under normal circumstances, Spatial Modeler will maintain the georeferenceable state, 
but some workflows might require that a georeferenceable raster be persisted in its georectified state. The 
Orthorectify operator fulfils this role. 

In ERDAS IMAGINE 2020 the Orthorectify operator has been updated with a number of new ports in order to 
combine functionality that previously required use of a Warp operator. 

• CellCalculationMethod 

• AllowApproximation 

• ApproximationTolerance 

• ApproximationMaxOrder 

• ApproximationGridSize 

• UsePyramids 
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Set to NoData 

 

The input NoDataValue port now accepts a Raster as input. This is useful for using one raster layer to mask 
another. 

If the input to NoDataValue is Scalar, the input raster stream is filtered so that every pixel value that matches 
the value specified on the NoDataValue port is marked as NoData in the output raster stream. 

If the input to NoDataValue is Raster, pixel locations in that raster that are marked as NoData are marked as 
NoData in the output raster stream. Note that areas outside the raster extent of the NoDataValue raster are 
considered NoData. 

Any pixels in the input raster stream that were already marked as NoData remain marked as NoData. The 
original value of pixels marked as NoData is not maintained. 

Shared Operators 

The following operators are licensed for use by licensed users of IMAGINE Advantage, IMAGINE 
Professional, GeoMedia Advantage, and GeoMedia Professional. 

Spatial Models using these operators will not be executable using IMAGINE Essentials or GeoMedia 
Essentials. 

Accumulate Flow 

 

The Accumulate Flow operator is part of a collection of grid operators used for hydrological analysis. It takes a 
FlowRaster and computes the flow accumulation for the entire surface. 

The AccumulationRaster produced by the Accumulate Flow operator contains data where each pixel value 
indicates the total number of pixels that contribute to the flow into that pixel. Pixels with a value of zero indicate 
headwater pixels (pixels that have no inflow, only outflow). Pixels with a value of NoData indicate no flow. The 
AccumulationRaster can be used as part of hydrological analysis workflows to identify river/stream networks or 
to identify drainage outlets, which can be used to find watershed (drainage basin) areas. 
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Calculate Flow 

 

Calculate Flow operator is part of a sequence of operators to identify drainage networks and watersheds.  

Calculate Flow operates on a Raster of continuous surface elevation data, such as a Digital Elevation Model 
(DEM). It generates a FlowRaster where each pixel value represents the direction that runoff would flow (in 
effect, the steepest slope) over the terrain.  

For each pixel, the slope of the line segment connecting the center of the pixel with the centers of the eight 
adjacent pixels is computed, taking both horizontal and vertical distance into consideration. The horizontal 
distance between the pixel center and the centers of the four directly adjacent pixels is equal to the pixel 
resolution. The horizontal distance between the pixel center and the centers of the four diagonally adjacent 
pixels is equal to the square root of two times the pixel resolution. 

Runoff is assumed to flow in the direction of the steepest downhill slope. "Ties" are allowed, that is, runoff can 
flow in more than one direction. Result pixel values indicate flow direction. 

For the purpose of hydrological analysis, one should first run the Fill Depressions operator on the DEMRaster 
to create a depression-less surface. This depression-less surface when used as the input DEMRaster to the 
Calculate Flow operator will produce a FlowRaster with no ambiguous flow. This new FlowRaster can then be 
used as input to the Accumulation Flow operator. 

Fill Depressions 

 

Fill Depressions operator is part of a collection of raster operators for hydrological analysis. It can be used as 
part of a sequence of raster operators to identify drainage networks and watersheds. 

Fill Depressions operates on a Raster of continuous surface elevation data, such as a Digital Elevation Model 
(DEM). It generates a FilledRaster where minor depressions in the surface have been removed. 

Find Watersheds 

 

In hydrological analysis, a watershed, or drainage basin, is defined as an area of land where all water (rainfall, 
streams, rivers, etc.) drains to a common outlet. Watersheds can be small, as in the area of land that drains 
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into a single reservoir or into a single stream segment, or large, as in the area of land that drains into the 
mouth of a major river. The Find Watersheds operator is part of a collection of raster operators used for 
hydrological analysis. It uses a FlowRaster to find the watershed areas where water drains to common flow 
outlets identified by the OutletRaster. 

FlowRaster must contain data that indicates the downhill drainage flow direction for each cell. 

OutletRaster contains data that uniquely identifies the common flow outlets for which watershed areas are to 
be found. The pixels that define a common flow outlet for a watershed should be assigned the same integer 
value. OutletRaster can define common flow outlets for multiple watersheds and each should be assigned a 
unique integer value. All pixels that do not define watershed flow outlets must be assigned to NoData. 
OutletRaster can define common flow outlets as a single or small set of pixels at the mouth of a stream or 
river, as a linear set of pixels defining a stream network or stream segments, or as clumps of pixels defining 
ambiguous flow zones. 

WatershedRaster produced by the Find Watersheds operator contains data showing the watershed areas 
found for each uniquely identified common flow outlet defined in the OutletRaster. The pixels that define a 
watershed area are assigned the same integer value as its associated common flow outlet pixels. All pixels 
that are not assigned to a watershed are set to NoData. 

Interpolate Using IDW 

 

Interpolate Using IDW performs an interpolation function that uses an Inverse Distance Weighting (IDW) 
algorithm to attempt to create a continuous raster data set from data that is incomplete. It computes values for 
NoData locations based on neighboring pixels with values. 

The operation works best with semi-continuous data such as contours or remote sensing imagery with gaps. 
For very sparse point data such as spot heights, geological surveys, clustered data, and random points, apply 
a kriging process to interpolate a continuous data set. Interpolate Using IDW should be used when processing 
the following scenarios: 

• For height density and/or regular spaced data points, such as elevation data, temperature data, rainfall data, or 
data from any continuously varying surface. 

• To fill in small gaps in satellite data, airphoto mosaics, or Digital Elevation Model (DEM) mosaics. 

• When there is a low degree of confidence in the exactness of the original data. 

• To create a DEM from contour or ridge-and-channel data. 

Format Support 

Cloud Optimized GeoTIFF 

ERDAS IMAGINE 2020 enables access to public and private Amazon S3 cloud storage services via the 
Retriever pane. One of the most effective formats to use via these services is the Cloud Optimized GeoTIFF 
(COG) format. 

Data accessed in this manner can be used in Spatial Model Editor or displayed via Image Chain. 
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MIE4NITF 

Time-series datasets are now being stored and delivered in the MIE4NITF standard. This can consist of 
hundreds, even thousands, of individual image frames stored in a NITF.  

ERDAS IMAGINE 2020 has been enhanced to enable opening multiple MIE4NITF frames into tools such as 
the Flicker tool in order to “play” the time-series, as well as being able to open individual frames for further 
exploitation. 
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GeoPackage 

Spatial Modeler and the Image Chain are capable of reading raster data stored in the popular GeoPackage 
format. Vector features can also be accessed through the Spatial Modeler. 

 



 

4 October 2019  33 

Luciad Terrain Service 

Luciad Terrain Services from LuciadFusion can be consumed in ERDAS IMAGINE as standard raster data 
sources, enabling their use for orthocorrection and other purposes. 

 

NetCDF 

Spatial Modeler and the Image Chain are capable of reading raster data in the NetCDF format. 

WMS display optimizations 

ERDAS IMAGINE’s 2D View works largely on the basis of pulling tiles from the source data for display. These 
tile requests (which cover an extent larger than the extent of the 2D View) appear to be causing WMS servers 
problems when they are expecting to return just one tile covering the entire desired extent. 

Consequently, for ERDAS IMAGINE 2020 we have introduced a second display mode/option for use with all 
WMS data layer types. This option is presented as a checkbox button in the Ribbon interface called 
"Continuous Roaming" and defaults to Off (that is, the new behavior). 

Turning this checkbox on will result in requests to the WMS server being for tiles rather than for the View 
extent. The benefit of turning the mode on is that tile requests can be sent and data rendered to screen while 
the extent is being panned or zoomed (for example, while the middle mouse button is still held down and the 
data being dragged). The downside is that the overall time to fill a View extent may be longer. 

Conversely if the mode is off (that is, the new behavior), the data request is only for the extent of the current 
View. This can be returned and rendered faster than with tiles. However the downside is that the request can 
only be sent when the roaming / zooming action stops (for example, when the middle-mouse button is 
released when panning, or the Auto Roam mode is stopped or paused). So while the data is being actively 
“moved”, you will see black around the prior data extent until you release the mouse. But for WMS layers the 
impression is generally that of increased performance. 

 

  

https://www.hexagongeospatial.com/products/luciad-portfolio/luciadfusion
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General ERDAS IMAGINE 

Image Chain Printing 

Imagery that has been displayed using the Image Chain can now be included into Map Compositions, sent to 
print devices and included in Send To… operations (Send to PowerPoint, Send to JPEG, Send to Geospatial 
PDF, etc). 

Optimal Seamline Generation 

Seamline generation is a crucial step in the mosaicing workflow to create seamless image mosaics. Images to 
be mosaiced usually have radiometric inconsistences and/or unresolved geometric misalignments. Seamlines 
are generated with a goal of avoiding such areas of radiometric inconsistency and large misalignments so that 
the resulting mosaic look seamless. 

A new seamline generation option that uses graph cut energy minimization framework to achieve the above 
stated goal is added in MosaicPro. Pixel values and gradients are employed as cost functions and graph cuts 
used to find the optional seamlines between/among images.  

 

3Dconnexion SpaceMouse Pro 

Support for the 3Dconnexion SpaceMouse Pro as a digitizing device is added for Viewplex based stereo 
viewers (Stereo Point Measurement tool, Terrain Editor, ORIMA, and PRO600) providing you with an 
additional input device choice. 
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Copy Selected Breaklines 

A new breakline editing capability that lets you copy an existing Breakline and place the copy at a specified 
offset from the selected Breakline is introduced in Terrain Editor. The capability can be accessed from the 
Terrain Editor Operators drop down menu, which is available in the Terrain Editing Panel. 

 

Editing Breakline Vertices 

Breakline vertex editing capability is enhanced. Breakline vertices can now be edited in the same way as 
editing mass points. Selecting the breakline that the vertex is part of is no longer necessary. 
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Dynamic update of Contours during Breakline editing 

Contours are now dynamically updated as breaklines are being edited, giving users an immediate feedback of 
the effects of the edits that is being made. Prior to ERDAS IMAGINE 2020, contours get dynamically edited 
while points are being edited, but were not updated when editing a breakline until the editing until the breakline 
is completed. With this update, contours are dynamically updated when either points and/or breakline are 
being edited. 

Consistent Style Library locations 

ERDAS IMAGINE 2020 now looks for style libraries only in the associated subdirectories of the etc directory in 
each of our "hives" ($PERSONAL, C:/ProgramData/ERDAS/ERDAS IMAGINE 2020, $IMAGINE_HOME). The 
software no longer looks directly in $PERSONAL or etc or in the sub-directories outside of etc (e.g. 
$IMAGINE_HOME/Colors or $PERSONAL/LineStyles). 

• Arrow styles: etc/Arrows 

• Colors: etc/Colors 

• Fill styles: etc/FillStyles 

• Line styles: etc/LineStyles 

• Symbols: etc/symbols 

• Text styles: etc/TextStyles 

If you have customized style libraries stored in any of the old locations you need to move them to the new 
locations in order to use them in ERDAS IMAGINE 2020 or later.  
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System Requirements 

ERDAS IMAGINE  

Computer/ Processor 
64-bit: Intel 64 (EM64T), AMD 64, or equivalent  

(Multi-core processors are strongly recommended) 

Memory (RAM) 16 GB or more strongly recommended 

Disk Space 

• 6 GB for software 

• 7 GB for example data 

• Data storage requirements vary by mapping project1  

Operating Systems 2, 3 

• Windows 10 Pro (64-bit) 4 

• Windows Server 2016 (64-bit) 

• Windows Server 2019 (64-bit) 

Software 

• OpenGL 2.1 or higher (this typically comes with supported graphics cards5) 

• Java Runtime 1.7.0.80 or higher - IMAGINE Objective requires JRE and can utilize any 
installed and configured JRE of version 1.7.0.80 or higher. 

• Python 3.6.x or 3.7.x (Python is optionally usable with Spatial Modeler).  

• Microsoft DirectX® 9c or higher 

• .NET Framework 4.0 

• OpenCL 1.2 with a device that supports double precision (cl_khr_fp64) if wanting to GPU 
accelerate NNDiffuse and other Operators 

• An NVIDIA card with CUDA capabilities is recommended for use with Deep Learning 

Recommended Graphics 
Cards for Stereo Display 

• NVIDIA® Quadro® K5200, K5000, K4200, K4000, K2200, K600, K420 6 

Recommended Stereo 
Display Monitors 

• 120 Hz (or above) LCD Monitors with NVIDIA 3D Vision™ Kit, or 3D PluraView system from 
Schneider Digital 7 

Peripherals 

All software installations require: 

• One Windows-compatible mouse with scroll wheel or equivalent input device  

• Printing requires Windows-supported hardcopy devices 8  

Software security (Hexagon Geospatial Licensing 2020) requires one of the following: 

• Ethernet card, or  

• One USB port for hardware key 

Advanced data collection requires one of the following hand controllers: 9 

• TopoMouse™ or TopoMouse USB™ 

• Immersion 3D Mouse 

• MOUSE-TRAK  

• Stealth 3D (Immersion), S3D-E type, Serial Port 

• Stealth Z, S2-Z model, USB version 

• Stealth V, S3-V type (add as a serial device) 

• 3Dconnexion SpaceMouse Pro 10 

• 3Dconnexion SpaceExplorer mouse 10 

• EK2000 Hand Wheels 

• EMSEN Hand Wheels 

• Z/I Mouse 

https://www.3d-pluraview.com/en/
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ArcGIS and GeoMedia 
Interoperability 

• ERDAS IMAGINE can be safely installed on a computer that has GeoMedia 2018 or GeoMedia 
2020 installed. However, for greatest compatibility, it is highly recommended to install matching 

versions (including Updates). 

• ERDAS IMAGINE 2020 requires GeoMedia 2020 for live linking. Order of installation does not 
matter. 

• ERDAS IMAGINE can interact with both types of personal Geodatabases (*.mdb and *.gdb).  

• ERDAS IMAGINE can be safely installed on a computer that has ArcGIS® versions 10.6 
through 10.7.1. 

• ERDAS IMAGINE and IMAGINE Photogrammetry can interact with ArcGIS Server 10.6 – 
10.7.1 Geodatabase servers (ArcSDE). To read or interact with an Enterprise Geodatabase, 
you must either:  

• Install and license the appropriate version of ArcGIS for Desktop versions 10.6 through 10.7.1, 
OR  

• Install the IMAGINE Geodatabase Support (based on ArcEngine 10.7) - requires no license 

Database Engines 

• PostgreSQL 9.6 with PostGIS 2.3: PostGIS can be used to store GeoMedia Features (.pfp) 

• Oracle Server 12c 12.2 64-bit: Oracle Server 12c can be used to store Oracle GeoRaster (.ogr) 
(requires Oracle Spatial), SDE Raster (.sdi) (requires ArcGIS for Server) and Oracle Spatial 

Features (.ogv) (requires Oracle Spatial), as well as GeoMedia Features (.ofp). 

• Microsoft SQL Server 2017 64-bit: Microsoft SQL Server 2017 can be used to store GeoMedia 
Features (.sfp) 

ERDAS IMAGINE System Requirements Notes 
1 Disk I/O is usually the slowest task in geospatial data processing. Faster hard disks improve productivity. 
Reading data from one disk, writing temporary data to a second disk, and writing data to a third disk improves 
performance. Disk arrays improve productivity, but some RAID options slow performance. Network disk drives 
are subject to network limitations.  

2 Server Operating Systems are not supported for IMAGINE Photogrammetry, ORIMA or ERDAS ER Mapper. 

3 The 3D stereo viewing and peripheral requirements of IMAGINE Photogrammetry limit its operating system 
options.  

4 ERDAS ER Mapper is not supported on Windows 8. It is considered Viable on Windows 8.1. 

5 Windows provides a generic OpenGL driver for all supported graphics cards. However, an OpenGL-
optimized graphics card and driver are recommended for these applications.  

6 Graphics cards certified with previous versions of IMAGINE Photogrammetry and ORIMA may also be 
compatible, but are not certified in the current version. 

7 Stereo Monitors certified with previous versions of IMAGINE Photogrammetry and ORIMA may also be 
compatible, but are not certified in the current version. 

8 HP-RTL drivers are recommended. Windows 64-bit print servers require 64-bit print drivers.  

9 Stealth S-Mouse (S2-S model) and MOUSE-TRAK are the only supported hand controllers in Stereo Analyst 
for ERDAS IMAGINE.  

10 3Dconnexion mice are supported in IMAGINE Photogrammetry. 
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Issues Resolved 

IMAGINE Essentials 

Issue ID Summary – 
IMAGINE 
Essentials 

Description / How to Reproduce 

IM-21970 ERDAS IMAGINE 
is creating gaps 

between images 
when zooming out 
(lost blocks) - 

caused by 3x3 
pyramid algorithm 

Customer reported that ERDAS IMAGINE 2014 v14.1 is creating gaps between multiple images in 
the viewer when zoomed fully out. The customer’s images are 8-bit IMG files. When zooming in, 

the gap between images disappears. 
 
Gaps are not visible when creating pyramid layers by using 2x2 kernel, but are visible when using a 

3x3 kernel. 

IM-39368 Viewer ERROR: 
bad allocation 

associated with 
large volume of 
image color table 

attributes 

Viewer does not handle images associated with a large number of attributes (i.e. color table). 
 

Test file displays with color scheme and without error in v10.1 & v11.0.5. Gets the bad allocation 
error in v13.0.2.  
 

Thematic input has 25 million rows and displays initially without error. The attribute table (with no 
color scheme) is displayed fine (except for scrolling to the very bottom). Get an error when trying to 
add colors from the view. Successfully added colors and class names using standalone raster 

attribute editor. Image is redisplayed fine after that. It apparently used the cache; it was still gray. 
 
Exited ERDAS IMAGINE, restarted, displayed the file. Colors are seen but now a “bad allocation” 

error is generated. 
 
08/07/14 09:35:09 SessionMgr(8668): ERROR: #2606 from 

erdas::viewerApp::ViewerControl::QueryAndOpenFile 
08/07/14 09:35:09 SessionMgr(8668): ERROR: bad allocation 

IM-41039 Unable to load 
Chinese or Arabic 
named data from 

Recent button 

1. Launch ERDAS IMAGINE 2018, 64-bit (bld:491)   
2. Load the data using Chinese characters in the filename 
3. Clear the viewer and try to reload the data from Recent button on the File chooser, from quick 

access tool bar.  
4. Observe that a warning thrown saying Data could not be found or invalid. 

IM-48233 New ribbonized 
Inquire Cursor is 

not recognized by 
applications such 
as Region Growing 
Properties tool 

The “At Inquire” button in the Region Growing Properties tool only works with the legacy Inquire 
Cursor. If the new ribbonized Inquire Cursor is active in a 2D View and the user clicks the “At 

Inquire” button in the Region Growing Properties tool a warning message is displayed that states 
“No Inquire Cursor in Window”.  
 
Steps to reproduce the problem:  

# Display the attached image in a 2D View  
# Activate the Inquire Cursor (Home tab > Information group > Inquire)  
# Open the Region Growing Properties tool (Drawing tab > Insert Geometry group > Grow menu > 

Growing Properties)  
# Click the “At Inquire” button in the Region Growing Properties tool.  
# A message pops up warning “No Inquire Cursor in Window”. 

IM-46524 Elevation values 

messed up when 
Basemap removed 
from 2DView 

Steps to reproduce:  

# Display lanier.img in a 2DView.  
# Left-click in the Elevation Part of the status bar and select Use Elevation Library.  
# Move the cursor around in the 2DView and notice that the elevation is around 350 meters.  

# Open the OpenStreetMap basemap in the 2DView containing lanier.img.  
# Move the cursor around in the 2DView and notice that the elevation is still around 350 meters.  
# Right-click on Basemap in the TOC and Remove Layer.  

# Move the cursor around in the 2Dview and notice that the elevation is now WAY below sea level 
(negative). 
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IM-46446 Elevation units are 
wrong in measure 
tool if target units 

are changed 

Steps to reproduce  
# Display and image in the 2DView.  
# Set the view's elevation source to "Use Elevation Library" and set the units to "feet".  

# Move your cursor around over the image and verify that the status bar is showing you the 
elevation in feet.  
# Start the measure tool.  

# Measure a Point.  
# See that the elevation is shown in the Point Measurement Description, but, although the value is 
in feet, the units say "meters." 

IM-46523 Elevation part of 

status bar does not 
remember or use 
the proper vertical 

units for saved 
elevation sources 

Steps to reproduce:  

# Open lanier.img in a 2DView.  
# Click in the Elevation Part of the status bar and select Use Elevation Library.  
# Click in the Elevation Part of the status bar and select "Show in Feet".  

# Move the cursor around in the 2DView and notice that the elevation is around 1200 feet.  
# Open lndem.img in Image Metadata and verify that it has Elevation Info and the Elevation Units 
are "feet".  

# Click in the Elevation Part of the status bar and select Choose Elevation Source  
# Select lndem.img as the Source File.  
# Change the Input vertical units to “feet”.  

# Click OK.  
# Move the cursor around in the 2DView and notice that the elevation still shows around 1200 feet.  
# Click in the Elevation Part of the status bar and select Use Elevation Library again.  

# Move the cursor around in the 2Dview and notice that the elevation now shows around 350 feet.  
 
You can get the same problem switching between any two previously-used elevation sources with 

different vertical units. 

IM-46522 Elevation Source 

Selector for 2D 
View should 
initialize input 

vertical units from 
Elevation Info 

Steps to reproduce:  

# Open lndem.img in imageinfo and verify that it has Elevation Info and the Elevation Units are 
"feet".  
# Open lanier.img in a 2D View.  

# Click in the Elevation Part of the status bar and select Choose Elevation Source  
# Select lndem.img as the Source File.  
# Notice that the Input vertical units remains "meters". It should be “feet”.  

IM-34455 Save as NITF is 
not responding 

(nothing happens) 
to an image that 
has been opened 

as Image chain 

1. Open any image as Image Chain. 
2. File > Save as > All layers as NITF, give proper location to save the output. 

3. Click yes for the dialog “save all the layers” 
Observe that nothing happens. 
 

IM-44349 Cloud Cover 
segment not 
displaying correctly 

as Image Chain 
(looks fine as 
Raster) 

Using a NITF with multiple image segments, including a cloud cover (CC) segment: 
 
# Start a 2D View, click the File Open icon (i.e. as Raster) and select the above NITF file.  

# In the Sub-Image tab turn on both the MONO and NODISPLY checkboxes.  
# Raster Options tab select Fit to Frame and click OK  
# The cloud layer has correctly displayed as solid 255s (cloud) and transparent 0s (no cloud)  

# Clear the View  
# File / Open / Raster as Image Chain and select the same NITF file.  
# Sub-Image tab turn on both the MONO and NODISPLY checkboxes.  

# Raster Options tab select Fit to Frame and click OK  
# This time the cloud layer has incorrectly displayed as solid grey across the entire extent. 



 

4 October 2019  41 

IM-37916 ImageChain 1:1 
display with 
Lagrange 

resampling is 
slower in ERDAS 
IMAGINE 2018 

when compared to 
ERDAS IMAGINE 
2016 Update 1. 

This is observed in the following 3 scenarios.. 
* if the multispectral image is opened in map space. 
* if both the pan and multispectral images are opened in image space. 

* if both the pan and multispectral images are opened in map space. 
 
Steps to reproduce, by taking the above 2nd scenario as example 

- Make sure that both the Pan and Multispectral images are copied into the same folder. 
- Select File --> Open --> Raster as Image Chain 
- In the file chooser that launches, select both the Pan and Multispectral images. 

- Go to the Raster Options tab and make sure that the Fit to Frame option is ON. 
- Click OK in the file chooser. 
- Once the images are displayed, go to Multispectral and Panchromatic tabs and change the 

resampling method for both the images as Lagrange. 
- From the Home tab click on the Reset option. 
 

Note the time it takes for the Reset. This time is slower in the above 3 cases when compared to 
ERDAS IMAGINE 2016 Update 1.  

IM-37917 ImageChain 
w/Lagrange 

resampling, jump to 
one end of an 
image using Inquire 

Cursor is slower in 
ERDAS IMAGINE 
2018 

- Select File --> Open --> Raster as Image Chain 
- In the file chooser that launches, select the Multispectral image. 

- Go to the Raster Options tab and make sure that the Fit to Frame option is ON. 
- Click OK in the file chooser. 
- Once the images are displayed, go to Multispectral tab change the resampling method as 

Lagrange. 
- From the Home tab click on the Reset option. 
- Launch the Inquire Cursor and feed in the coordinates of bottom right side corner and hit enter. 

 
Note the time it takes for the Inquire Cursor to move and display the image. This time is slower 
compared to ERDAS IMAGINE 2016 Update 1 

IM-29894 ERDAS IMAGINE 
is ignoring the 

overviews for 
grayscale (and 
RGB) TIFF image 

with JPEG 
compression 

Overviews are not considered by Image Chain for grayscale image with JPEG compression. 
Due to this it is taking a long time to load the image even though the image has a full set of 

overviews.  
For the same image if we use another compressions like LZW then overviews are considered and 
displays the image in seconds.  

Also, RGB (also w/ JPEG compression) version of same image displays very quickly, indicating the 
overviews are being seen and used. Pyramid info for gray scale image is showing as no pyramid 
layers present in ERDAS IMAGINE 2016 software.   

IM-47229 Problem of opening 
as image chain for 

image calibrated 
with DEM with 
NoData 

An image was geometrically calibrated using a DEM that was of smaller extent than the image (or 
which otherwise contained NoData locations) 

 
When opening as Image Chain in the Viewer, the Low Right quadrant is not correct. It should be no 
data area (background color), but showing partial raster.  

IM-46335 Selecting vector 

symbol from 
"Other" group 
throws errors and 

sometimes crashes 

To recreate:  

# Display a polygon shapefile  
# Vector tab > Style > Styles group > Properties button (to open Fill Style Chooser)  
# Custom Tab > Use Pattern checked on > open Symbol menu > Other > Pick any Menu, any 

Symbol. Errors are thrown.  
# Repeat steps above, then no errors!  
 

Behavior is inconsistent. Sometime crashes occur. Sometimes errors don’t occur.  
 
02/10/18 12:26:26 viewer vector “shapefile.shp”;  

02/10/18 12:28:26 SessionMgr(17748): ERROR: #1 from 
eant_CoordSysConversionConvertAndTransformYScale  
02/10/18 12:28:26 SessionMgr(17748): ERROR: Error returned from 

eant_CoordSysConversionScaleAndTransformY  
02/10/18 12:28:26 SessionMgr(17748): ERROR: #2 from 
eant_CoordSysConversionScaleAndTransformY  

02/10/18 12:28:26 SessionMgr(17748): ERROR: Error returned from 
eant_CoordSysConversionScaleY  
02/10/18 12:28:26 SessionMgr(17748): ERROR: #3 from eant_CoordSysConversionScaleY 



 

4 October 2019  42 

IM-47264 "Choose Sensor" 
doesn't use its 
.SAF settings 

correctly still 

Open a three-band RGB image into a 2D View as raster.  
Go to the Multispectral tab.  
In the Bands group note that it has defaulted to Choose Sensor and a RGB order of Layer_1, 

Layer_2, Layer_3 (it should based on default Preferences).  
Now, not a lot of people realize, but "Choose Sensor" is just a standard .SAF file, with wavelengths 
set in it. So you should be able to pull down the Common Band Combinations list.  

"False Color Infrared" shouldn't show up on the list - it shouldn't be present based on the 
wavelengths defined in 3BandDefault.saf. 

IM-46915 "Choose Sensor" 
doesn't use its 

.SAF settings 
correctly 

Open a three-band RGB image into a 2D View as raster.  
Go to the Multispectral tab.  

In the Bands group note that it has defaulted to Choose Sensor and a RGB order of Layer_1, 
Layer_2, Layer_3 (it should be based on default Preferences).  
Now, Choose Sensor is just a standard .SAF file, with wavelengths set in it. So you should be able 

to open the Common Band Combinations list and select True Color.  
But when you do, the RGB display order changes to Layer_1, Layer_1, Layer_1, which is incorrect.  
False Color Infrared should not be present based on the wavelengths defined in 3BandDefault.saf.  

Choose Sensor option has similar problems for other numbers of bands too. 

IM-46880 Clearing View with 

Subset’s Inquire 
Box up crashes 
ERDAS IMAGINE 

Display an image in a 2D View (e.g. lanier.img) 

On the Multispectral tab start Subset and Chip  
With the Subset and Chip dialog (and its associated Inquire Box) still active, click the Clear View 
icon on the Quick Access Toolbar.  

ERDAS IMAGINE crashes  
 
Doesn’t happen in ERDAS IMAGINE 2016 v16.1 

IM-41174 ERDAS IMAGINE 

crashes with 
Measurement tool 
operation 

1.Launch ERDAS IMAGINE 2018 

2.Load a WorldView-2 GeoTIFF image. 
3.Now Click Measure button from Home tab > Information group  
4.Select Shadow height from Layover from Measurement tab > Measure  
5.Observe Cursor changes to cross  

6.Keep the cursor as cross and clear the viewer from quick access tool bar  
7.Now with cross Cursor click on the viewer and observe ERDAS IMAGINE crashes  

IM-48070 Viewer Banner 
(Title Bar) is 

Erased 

When a 2D View is resized smaller and then expanded to original size, parts or all of the View Title 
Bar Text is erased. 

IM-47497 Problem with HxIP 

basemap not 
reprojecting 

Failure Scenario  

1. Display orthorectified IMG image (projected to UTM) 
2. Fit Layer to Window (note that View projection is UTM)  
3. Click the Basemap button and select HxIP  

4. Provide login credentials, Test and (if successful) click Add and then OK  
5. Note that the background of the first image displays as red x’s 
 

Success Scenario  
1. Click the Basemap button and select HxIP  
2. Provide login credentials, Test and (if successful) click Add and then OK  

3. Note that the basemap displays fine. View projection is Lat/Lon  
4. Display orthorectified IMG image (projected to UTM) 
5. In the Contents pan, right click on the IMG image and select Fit Layer to Window  

6. Note that both images display fine  
 
There’s an issue with the projection the data is being requested in. 
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IM-48186 Variables option 
cannot be changed 
in Batch Command 

Editor for Map 
Model to World File 
process 

When trying to use the Map Model to World File image metadata command in a batch process, the 
Variables menu in the Batch Command Editor is greyed out and stuck at “Original commands”. You 
cannot choose the option “One input, one or more outputs”. The command was only half auto-

variablized, i.e., a variable is created for the input file, but a variable is not created for the output 
world file.  
 

The original command in ERDAS IMAGINE 2016 is:  *imagecommand c:/input/input1.tif -
exportworld c:/output/input1.tfw -meter imagecommand*  
 

The “original” command in ERDAS IMAGINE 2018 is:  *imagecommand ‘$(Input)’ -exportworld 
c:/output/input1.tfw -meter imagecommand*  
 

You can work around this by creating an output variable and inserting it into the command but it is 
not straightforward to the user.  

IM-45559 Multi-point 
Geometric 

correction dialog 
crashes while 
trying to mark a 

GCP 

1) Launch ERDAS IMAGINE and open a WorldView-2 GeoTIFF image into a 2D View   
2) Go to Multispectral tab -> Control Points  

3) Select Worldview RPC under the Set Geometric model dialog and Hit OK  
4) Close the dialogs that come up [by clicking Cancel repeatedly] and now click on the Create GCP 
icon on Multipoint Geometric correction window and click on the main viewer to collect the point, 

note that it throws an error message, Click OK on it  
 
Observe that the warptool.exe crashes after clicking OK on the error message   

IM-44393 64-bit exporttif 
outputting "E" for 

"Software" TIFF tag 

# Make sure exporttif is configured to run 64-bit.  
# Manage Data tab | Conversion group | Export Data.  

# Set the Format to "TIFF" (not "TIFF Direct Write").  
# Select any input image.  
# Enter an output filename.  

# Click OK.  
# Take all defaults and click OK on the Export TIFF Data dialog.  
# Open the resultant TIFF in Image Info.  

# Click on the TIFF Info tab.  
# Expand the Image folder and click on the TIFF Tags folder.  
# The value of the Software tag is "E".  

# If you do this workflow again with exporttif configured to run 32-bit, the value of the Software tag 
is "ERDAS IMAGINE".  

IM-19706 Area Fill tool 
corrupts TIFF 
images 

After using the Area Fill tool on a TIFF image and saving the image, it becomes corrupted and does 
not appear correct when you clear it from the 2D View and display it again. This problem does not 
occur in ERDAS IMAGINE 2014 v14.1 

 
How to reproduce: 
1. Open the TIFF image in a 2D View with the No Stretch raster option enabled.  

2. Draw an AOI polygon in any area of the image. Make sure that the AOI is selected.  
3. Select TIFF image in the Contents panel. 
4. Open the Area Fill tool by clicking on the Fill button in found in the Edit group under the 

Multispectral tab.  
5. In the Area Fill tool, make sure that the Function option is set to Constant and leave the Fill With 
values is set to 0.0.  

6. Click the Apply button to convert the pixel values within the AOI polygon to the new pixel value. 
An Attention message opens "This layer is using a data stretch lookup table. When editing pixel 
values you may want to remove the data stretch lookup table. Do you want to do this now? Click 

Yes. 
7. Another warning message displays “Since this function modifies the pixel values of the image, 
you may wish to recalculate the statistics and histogram for the layer before doing any other 

operation that depends on this data.” Click OK. 
8. Close the Area Fill tool. 
9. Save your image.  

10. Remove your image from the 2D View and redisplay it. Notice that the image has changed, but 
not like it should have. 
11. This problem does not happen when using an IMG format image instead of a TIFF image. 
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IM-10616 ERDAS IMAGINE 
JFIF (JPEG) 
cannot read 

Progressive JPEG 
profile 

Customer reported that they cannot import JPG with JGW file into IMG or TIFF formats. They are 
also not able to open the JPG file in ERDAS IMAGINE. However they can open/ import the JPG file 
in ER Mapper 2013 

 
The importer gives error message while importing : “Unsupported SOF Marker type 0xc2 
 

While opening the file in the 2D View ERDAS IMAGINE gives : “File open error (0-Unknown error” 

IM-44698 Artifacts in 
Sentinel-2 images 
when directly 

viewing the *.safe 
file in 2D View as 
well as after 

importing 

Customer reported that they can find artefacts in Sentinel-2 images when directly viewing the *.safe 
file in a 2D View as well as after importing the *.safe file into *.img by means of the Sentinel-2 
Direct Read and Sentinel-2 manifest importers. The artifacts seems to be due to the granule tile 

borders.  
 
Seems to affect only imagery from before December 2016 when the data structure of Sentinel-2 

was re-organized.  
 
Steps to Reproduce:  

1. Open the Sentinel2 *.safe file in IMAGINE Viewer. Zoom to a granule edge. You see the broken 
straight lines artifacts in between granule tiles. 
2. Import the Sentinel 2 *.safe file by means of the Sentinel 2 Direct Read and Sentinel-2 manifest 

importer. Then open the imported output file in IMAGINE Viewer. Zoom to a granule edge. You see 
the broken straight lines artifacts in between granule tiles. 

IM-39173 Opening a 
hyperspectral 
image in ImageInfo 

takes long time 

To reproduce the problem open a hyperspectral image in a 2D Viewer.  
Go to IMAGINE Home tab and click Metadata button. Notice that it takes quite long time before the 
image info is shown on ImageInfo dialog box.  

On one test machine, it takes more than 10 seconds to open an AVIRIS scene in ImageInfo, It has 
224 bands and whose width and height are 530 pixels and 301 pixels. 

IM-12677 Request to add 
missing ground 
control point gcc 

files in ERDAS 
IMAGINE example 
data 

Request to add missing ground control point gcc files in the ERDAS IMAGINE example data in the 
download page.  
 

In the ERDAS IMAGINE 2014 Online Help documentation, in the "Refine the DEM Extraction 
Workflow exercise", it has been mentioned about using two Ground Control Points files (gcc files) : 
"uluru_reference-gcp.gcc" and the "uluru_input-gcp.gcc" file. However the customer couldn’t find 

those two gcc files in the ERDAS IMAGINE example data.  
 
These are now downloadable as part of the ERDAS IMAGINE Radar Example Data download. 

IM-43563 Tiff files with Thai 

characters in their 
names fail 

An ERDAS APOLLO customer is seeing failures due to ERDAS IMAGINE not being able to handle 

tiff files with Thai characters in them, for example:  
 

เชยีงราย.tif  

 
The issue is not restricted to TIFF. If you rename an IMG file, create pyramids (rrds) and then 
attempt to open the IMG file, you get errors referring to the pyramids not being found. 

IM-44567 64-bit ImageInfo 
displaying TIFF 

GTCitationGeoKey 
incorrectly 

# Open a TIFF file in *64-bit* ImageInfo.  
# Click on the TIFF Info tab.  

# Expand the Image folder and the GeoTIFFKeys folder.  
# The GTCitationGeoKey is displayed in what looks like Chinese characters, although the values of 
the other tags look fine.  

 
 

IM-46884 Pleiades DIMAP v2 
image stats 

reversed for red 
and blue bands 

 If you calculate statistics (for example in Image Info) for a Pleiades DIMAP v2 image the resulting 
stats are correct. Whereas if you look at the "raw" DIM*.XML file (with all .aux files, etc., deleted 

first) ERDAS IMAGINE is trying to use the statistics it finds in the .XML header, but is associating 
the stats in the wrong order. 

IM-44990 Socet GRID file 
opens in 32 bit but 
not 64 bit 

Open a specifc type of Socet GRID *.dth file in a 32-bit 2D View. Image appears.   
Open the same file in 64 bit view. Get error: "Header identifier did not match"  
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IM-37447 Additional empty 
"Image" segments 
shouldn't be saved 

to IMG header 

Open a multi-segment NITF image in a 2D View (using default settings so only one image segment 
is opened). 
File / Save As / Top Layer As.. to an IMG format output. 

Open the resulting IMG file in ImageInfo and click on the NITF tab. 
Note that despite the fact that there is only a single image segment physically present in the IMG, 
all the original Image segments have been copied across even though they do not have the 

associated data to go with them.  
 
Not only is not removing them confusing, it also causes ERDAS IMAGINE problems - e.g. if you try 

to Save All Layers as NITF, the NITF Exporter crashes. 

IM-46218 TIFF pyramids not 
recognized (APM 
fails with .tiff) 

APM fails with customers .tiff images. All is correct with customer's block setup. Image Info does 
not recognize pyramid layer algorithm. Images do not display correctly if you "fit to frame" in 
IMAGINE Viewer. And in IMAGINE Photogrammetry, image is displayed only on a small section of 

image footprint. 
Re-generating pyramids in IMAGINE Photogrammetry does not solve the problem. Only 
workaround is to convert the imagery to another format. So, I imported these files to .img format 

and re-attached them to the block file and then tested APM. APM run successfully collected 90+ 
points using default pattern. 

IM-47024 JPEG2000 
exporter in ERDAS 
IMAGINE gives 

error message with 
ArcGIS created 
*.img file 

Customer reported that JPEG2000 exporter (Manage Data > Export Data > JPEG 2000) in ERDAS 
IMAGINE gives error message with ArcGIS created *.img file. The JPEG 2000 export process runs 
all the way through, and nearly at the end ERDAS IMAGINE gives an error, saying: "Layer_1INode 

already exist for file *.aux".  
 
The customer‘s *.img file was created by ArcGIS HillShade Tool from a DEM file created by 

ERDAS IMAGINE’s MosaicPro .  
 
Even if the ERDAS IMAGINE JPEG 2000 exporter gives the following error message, it creates a 

valid output JPEG 2000 file.  
 
 “The file *.jp2 cannot be deleted  

because it is in use by another application.  
Close the file and then press 'Retry' to continue,  
or press 'Cancel'.  

IM-46584 Help - ML Review 
Tab Hyper link 

navigating to 
Review Tab of 
Zonal change 

1.Launch ERDAS IMAGINE 2018 Update 2  
2.Launch Machine Learning Layout from File > Layout  

3.Select ML Process tab and click F1  
4.Observe ML Review Tab Hyper link navigating to Review Tab of Zonal change layout.  

IM-35331 Errors when trying 

to display features 
from Oracle 
Features Proxy 

(.ofp) and Spatial 
Feature (.ogv) 

Customer reported that ERDAS IMAGINE gives errors when they tried to display features from both 

Oracle Spatial Feature (.ogv) and Oracle Features Proxy (.ofp),  
The customer has been able to create a connection using both Oracle Spatial Feature (.ogv) and 
Oracle Features Proxy (.ofp), When trying to load .ogv, he gets the error:  

"Invalid input ProProjection structure", then "Invalid input units name".  
 
The feature shows up in the legend, but is not visible in the display (but the bounding box can be 

seen if turned on).  
 
When trying the .ofp, he gets the error: "Could not open layer. Invalid connection parameters". He 

gets nothing in the legend or display window.  

IM-35332 ERDAS IMAGINE 

is unable to display 
features from 
Oracle Spatial 

Feature (.ogv) and 
Oracle Features 
Proxy 

Customer reported that ERDAS IMAGINE is unable to display features from both Oracle Spatial 

Feature (.ogv) and Oracle Features Proxy (.ofp), when connected to the database using credentials 
of a user who is non-owner of the database. 
 

If the customer uses the credentials of the owner or the credentials of the System DBA, he can 
display the feature in ERDAS IMAGINE. However, customer is not seeing any problem with the 
same data in GeoMedia. It’s only in ERDAS IMAGINE, which is not displaying the vector. 

Recreated the problem in ERDAS IMAGINE and in another popular GIS software. 

IM-42876 Unable to open 
point features from 
an Oracle database 

Using specific Oracle database connection, try to display any points features available in it. Notice 
that there are couple of error messages and the display fails.  
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IM-48922 Proxy gdb file 
access, without 
connecting to 

geodatabase 
throws error, which 
is not clear 

ERDAS IMAGINE 2018 Update 2 could not use an existing .gdb Geodataabse proxy file to access 
the Geodatabase  
 

IM-48919 Trying to display a 

Point Feature class 
in gdb (having 
single point) fails in 

ERDAS IMAGINE 

ERDAS IMAGINE 2018 Update - Trying to display a Point Feature class in gdb (having single 

point) fails in ERDAS IMAGINE 2018 Update 2. Whereas Point Feature Class with >1 point 
displays fine.  
 

IM-48918 Supported version 

of Geodatabase 
logged in session 
log needs to be 

updated 

In ERDAS IMAGINE > File > Open > Vector layer > ArcGIS Geodatabase (*.gdb) >  Click Connect.  

 
Session log reports:  
 

17/05/19 15:24:52 SessionMgr(5324): Detected geodb version  10.7  
17/05/19 15:24:52 SessionMgr(5324): Unsupported version of GeoDatabase support located. 
Please note that IMAGINE is only supported for version up to 10.2.  

IM-47243 Fail to launch Texel 

Mapper 

1. Launch ERDAS IMAGINE 2018 (64-bit) 

2. Launch Texel Mapper from Toolbox tab > Common group > Stereo Analyst drop down.  
3. It fails.  

IM-45530 Unable to load ers 
file associated with 
TIFF file in ERDAS 

IMAGINE 2018 

1.Launch ERDAS IMAGINE 2018 (64-bit)  
2.Try to load a specific .ers file and observe Message thrown saying image has no layers.  
3.Sessionlog saying ERS Raster error:Filetype unkown.  

 

IM-44887 Output created 
using LaGrange 
resampling differs 
from the output 

generated using 
other resampling 
methods 

Giving the image and the DEM provided as input to "Orthorectify without GCP" option, generate 2 
outputs one with LaGrange resampling method and the other with any other resampling method 
from the rest available. Open the 2 outputs in 2 different viewers and notice that in one portion of 
the image the outputs differ.  

IM-39311 Generating 

pyramids takes an 
unexpectedly long 
time because of the 

binary "use 
multithreading" 
hyperspectral 

preference 

Pyramid layers are taking an unexpectedly long time to be generated for hyperspectral images.  

 

IM-41083 unit test failure 

when locale is set 
to German (bug in 
etxt::tostring) 

The locale on my development machine is set to German (Control Panel | Region | Formats tab | 

Format = "German (Germany)").  When running the eCommon etxtUnitTest::test_ToString_Double 
unit test, it fails, because the string has a comma as the decimal separator.  The problem is that the 
fallback condition at the bottom of etxt::tostring is just calling etxt_Text_sprintf, which is ignoring the 

useCLocale parameter passed to etxt::tostring (). 

IM-48813 DEM Tools 
Revalue function 
does not allow 

DEM recode values 
to be specified 

DEM Tools Revalue application does not add recode values from Range(s) window to the Range 
list. The program does not run unless recode values are added to the Range list.  
Does not work with any data type (i.e 1, 2, 4, 8, 16 and 32 bit signed/unsigned integers, 32 and 64 

bit float).  
 
Worked correctly in ERDAS  IMAGINE 2016  

 
To recreate:  
Open Terrain tab > DEM Tools > Revalue  

Input DEM: lndem.img 
Add 1300 to Range(s) window  
New Value: 0+ 

Select Add Range to List.  
There is no response to this request 
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IM-43195 64-bit VersionTool 
reporting garbage 
for Date/Time 

Stamp 

Session | DLL Information  
Class: Raster Formats  
DLL Instance Information tab  

Instance: ADRG (and others)  

Description shows Date/Time Stamp: 㜲䨠湡㈠‸㌱㈺㨰〱 

IM-46366 Coordinate system 
option in 
Measurements 

panel automatically 
flips if zoom is 
performed in the 

viewer 

• Launch the Preference Editor and change the preference for the following option to Lat/Lon 
(WGS 84).  

• Viewing category > Viewer > Show Coordinates As  

• Open an image in the viewer and select the Measure option from the Information group of 
Home tab.  

• In the Measurement tab under the Setup group notice that the Coordinate Type is Lat/Lon.  

• Measure a few points and notice that the measurements are displayed as Lat/Long.  

• Perform some zoom in the viewer.  

• Notice that the coordinate type in the measurements panel flips to Map.    

IM-40172 Image Command 

does not print 
statistics when 
using ‘Compute 
Statistics’ and ‘Print 

To File’ together 

Using the ‘Compute Statistics’ and ‘Print To File’ options together does not print image statistics to 

file when the .aux does not exist prior to running Image Command.  
 
If you run Image Command only using ‘Compute Statistics’ first and then run Image Command 
using ‘Print To File’, the image statistics are printed to file.  

 
To recreate:  
# Be sure doubl_float.aux does not exist  

# Run Image Command, open doubl_float.tif  
# Check ‘Compute Statistics’ and ‘Print To File’, specify .txt  
# OK  

Open the .txt with WordPad. Image statistics are not present.  

IM-46755 SARVI index fails 
with "Empty data 
on port" error 

On the Raster tab, open the Indices dialog  
Specify Input as lanier.img  
Set Category to All  

Select Index: SARVI  
Click Preview (or OK after providing an output filename) 
Error:  

Spatial Model failed in Multiply. The error was "Empty data on port".  

IM-44665 If you try to save 

the session, 
ERDAS IMAGINE 
crashes 

Go to File > Save > General Save Options > Session  

ERDAS IMAGINE crashes 

IM-49543 Choosing this .TIL 

file in the file 
chooser caused 
IMAGINE crash 

Clicking on a specific DigitalGlobe .TIL file in the file chooser causes ERDAS IMAGINE to crash. 

 

IM-49605 Generate System 
Report showing 

wrong operating 
system information 

1.Launch ERDAS IMAGINE 
2.Generate System report from File > Session  

3.Click OK (make sure all check boxes checked on)  
4.Provide the path for report  
5.Open the report generated and observe operating system information shown as  

Microsoft Windows 8 64-bit (Build 9200) for Windows 10 machine  

IM-47470 Opening individual 
Algorithm file 
crashes ERDAS 

IMAGINE 

1.Launch ERDAS IMAGINE 
2.Copy Algorithm file RGB.alg to local folder  
C:\Program Files\Hexagon\ERDAS IMAGINE 2018\examples\ermapper\data_types\airphoto  

3.Try to open the RGB.alg from File > Open > Algorithm  
4.Observe ERDAS IMAGINE crashes.  
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IM-48520 Chart to Chart 
change detection 
throwing fault 

message in 
session log "Client 
Failed to connect to 

server" 

1.Launch ERDAS IMAGINE  
2.Launch Chart to Chart change detection from Raster > Change Detection > Change Detection 
Tools > Chart to chart  

3.Provide the inputs as chart1-geo.tif, chart2-geo.tif  
4.Provide the output name and click run  
5.Observe Process run and output got generated but session log showing -Client Failed to connect 

to server  
 
+Session log:+  

17/04/19 14:47:17 SessionMgr(9640): Connection success for the external process 'eWkspace_64'  
17/04/19 14:47:31 C:/Program Files/Hexagon/ERDAS IMAGINE 
2019/bin/x64URelease/smguiprocess.exe 

$IMAGINE_HOME\etc\ZonalChange\ChartToChartChangeDetection.gmdx  
17/04/19 15:01:30 C:/Program Files/Hexagon/ERDAS IMAGINE 
2019/bin/x64URelease/smprocess.exe 

$IMAGINE_HOME\etc\ZonalChange\ChartToChartChangeDetection.gmdx Chart To Chart Change 
Detection.Chart 1=d:\2019\data_delete\chart\chart1-geo.tif Chart To Chart Ch  
ange Detection.Chart 2=d:\2019\data_delete\chart\chart2-geo.tif Chart To Chart Change 

Detection.Change Image=d:\2019\16-04-2019\charttochartchange.img Chart To Chart Change 
Detection.Threshold=0.5  
17/04/19 15:01:30 SessionMgr(9640): smguiprocess.exe exited with status 1.  

17/04/19 15:01:31 SessionMgr(9640): Running spatial model 
($IMAGINE_HOME\etc\ZonalChange\ChartToChartChangeDetection.gmdx) with port values (Chart 
To Chart Change Detection.Chart 1=d:\2019\data_delete\chart\chart1-geo.tif,Chart To Chart 

Change Detection  
.Chart 2=d:\2019\data_delete\chart\chart2-geo.tif,Chart To Chart Change Detection.Change 
Image=d:\2019\16-04-2019\charttochartchange.img,Chart To Chart Change 

Detection.Threshold=0.5).  
17/04/19 15:01:31  
17/04/19 15:01:34 SessionMgr(9640): Running command line: C:/Program Files/Hexagon/ERDAS 

IMAGINE 2019/bin/x64URelease/imagesegmentation_fls.exe -maxpixels "2000000" 
"C:\Users\agangumo\AppData\Local\Temp\SM-da28-05b1-b5f9-1e10-010952\d963f69d-9911-
4a3e-9  

aef-069d13813d12" "C:\Users\agangumo\AppData\Local\Temp\SM-da28-05b1-b5f9-1e10-
010952\1bd12244-1cdf-493f-ae92-3d74f2a907b7" -scale "100" -scalemin "10" -scalemax "2000" -
spectral "1" -texture "0" -shape "0.29999999999999999" -size "0.30000000000000004"  

-min "10" -max "100000" -randomcolor "1" -meter  
17/04/19 15:01:34 SessionMgr(9640): Connection success for the external process 'FLS 
Segmentation'  

17/04/19 15:01:35 SessionMgr(9640): Client Failed to connect to server :No connection could be 
made because the target machine actively refused it  
17/04/19 15:01:36 SessionMgr(9640): Client Failed to connect to server :No connection could be 

made because the target machine actively refused it  
17/04/19 15:01:37 SessionMgr(9640): Client Failed to connect to server :No connection could be 
made because the target machine actively refused it  

17/04/19 15:01:38 FLS Segmentation(6664): Performing FLS Segmentation  
17/04/19 15:01:38 FLS Segmentation(6664):  Input File: 
C:/Users/agangumo/AppData/Local/Temp/SM-da28-05b1-b5f9-1e10-010952/d963f69d-9911-4a3e-

9aef-069d13813d12  
17/04/19 15:01:38 FLS Segmentation(6664):  Pixel:Segment Ratio:  100  
17/04/19 15:01:38 FLS Segmentation(6664):  Spectral Weight: 1.00  

17/04/19 15:01:38 FLS Segmentation(6664):  Texture Weight: 0.00  
17/04/19 15:01:38 FLS Segmentation(6664):  Size Weight: 0.30  
17/04/19 15:01:38 FLS Segmentation(6664):  Shape Weight: 0.30  

17/04/19 15:01:39 FLS Segmentation(6664): Segmenting Tile 1  
17/04/19 15:01:48 FLS Segmentation(6664): Segmenting Tile 2  
17/04/19 15:01:50 SessionMgr(9640): external process exited normally.  

17/04/19 15:01:52 SessionMgr(9640): Spatial model ran successfully.  
17/04/19 15:01:52  
17/04/19 15:01:53 SessionMgr(9640): smprocess.exe exited normally. 
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IM-46613 Opening map 
composition file 
having '(' in the file 

path of referenced 
images, crashes 
ERDAS IMAGINE 

2018 

Launch ERDAS IMAGINE 2018.  
Open map composition file  "withparentheses.map"  
Observe user is prompted to substitute raster file path. specifying to use the Original file through 

substitute crashes ERDAS IMAGINE.  
 
Whereas in ERDAS IMAGINE 2016 Update1, throws error.  

6/10/18 14:57:39 SessionMgr(7020): ERROR: #453 from efnp_FileNodeListGetNonNodePart  
26/10/18 14:57:39 SessionMgr(7020): ERROR: efnp_FileNodeListGetNonNodePart fail  
26/10/18 14:57:39 SessionMgr(7020): ERROR: #774 from efnp_FileNodeListGet  

26/10/18 14:57:39 SessionMgr(7020): ERROR: FileNodeListParse failed  
26/10/18 14:57:39 SessionMgr(7020): ERROR: #1457 from FileNodeListParse  
26/10/18 14:57:39 SessionMgr(7020): ERROR: Parse error; <FileNodeListItemSpec> at position 62 

is preceded by a <DirectoryName>  
26/10/18 14:57:39 SessionMgr(7020): ERROR: #1148 from edis_TrueColorCreateLayerByName  
26/10/18 14:57:39 SessionMgr(7020): ERROR: 

erdas::raster::GridCoverageIdentifierEFNP::FromFileNode failed  
26/10/18 14:57:39 SessionMgr(7020): ERROR: #507 from 
erdas::raster::GridCoverageIdentifierEFNP::FromFileNode  

26/10/18 14:57:39 SessionMgr(7020): ERROR: efnp_FileNodeListGetNonNodePart failed  
26/10/18 14:57:39 SessionMgr(7020): ERROR: #453 from efnp_FileNodeListGetNonNodePart  
26/10/18 14:57:39 SessionMgr(7020): ERROR: efnp_FileNodeListGetNonNodePart fail  

26/10/18 14:57:39 SessionMgr(7020): ERROR: #774 from efnp_FileNodeListGet  
26/10/18 14:57:39 SessionMgr(7020): ERROR: FileNodeListParse failed  
26/10/18 14:57:39 SessionMgr(7020): ERROR: #1457 from FileNodeListParse  

26/10/18 14:57:39 SessionMgr(7020): ERROR: Parse error; <FileNodeListItemSpec> at position 62 
is preceded by a <DirectoryName>  
26/10/18 14:57:39 SessionMgr(7020): ERROR: #595 from 

erdas::mapComposerApp::MapComposerControl::Open  
26/10/18 14:57:39 SessionMgr(7020): ERROR: 
erdas::mapComposerApp::MapComposerControl::Open failed  

26/10/18 14:57:39 SessionMgr(7020): ERROR: #549 from 
erdas::mapComposerApp::MapComposerControl::Open  
26/10/18 14:57:39 SessionMgr(7020): ERROR: edis_MapComposerBuildFrames failed  

26/10/18 14:57:39 SessionMgr(7020): WARNING: #1 from edis_MapComposerBuildFrames  
26/10/18 14:57:39 SessionMgr(7020): WARNING: Error filling in frames  
26/10/18 14:57:40  

26/10/18 14:57:40 SessionMgr(7020): WARNING: #1 from edis_MapComposerPopulateFrame  
26/10/18 14:57:40 SessionMgr(7020): WARNING: Couldn't open truecolor layers:  
26/10/18 14:57:40 

//ingrnet.com/in/sgi/geospatial/gs2/imaginedata/pixeldata/del/(copy)/limerick_2007_subset.img(cop
y)/limerick_2007_subset.img(:Layer_1)  
26/10/18 14:57:40 

//ingrnet.com/in/sgi/geospatial/gs2/imaginedata/pixeldata/del/(copy)/limerick_2007_subset.img(cop
y)/limerick_2007_subset.img(:Layer_2)  
26/10/18 14:57:40 

//ingrnet.com/in/sgi/geospatial/gs2/imaginedata/pixeldata/del/(copy)/limerick_2007_subset.img(cop
y)/limerick_2007_subset.img(:Layer_3) 

IM-47986 Reprojecting MrSID 
image much slower 
in ERDAS 

IMAGINE 2018 vs 
ERDAS IMAGINE 
2015 

It was reported that ERDAS IMAGINE 2018 takes over two hours to reproject a 17 MB MrSID 
image, but the same image can be reprojected in ERDAS IMAGINE 2014 in 20-30 seconds. The 
same pattern can be observed with other larger MrSID files. Reprojecting similar images in other 

formats such as IMG or TIFF only takes 20-40 seconds in ERDAS IMAGINE 2018.  

IM-11214 Double && in 

Preferences 

File > Preferences  

Under User Interface folder you will see the entry “User Interface && Session” 

IM-42604 After using 

Add/Change 
Projection in Edit 
Image Metadata, 

the Unit disappears 
in the metadata 

Reported that after editing or adding Projection in a file, using Edit Image Metadata, the Unit 

disappears in the metadata.  
 
To recreate the problem, use the customer’s data in Edit Image Metadata or ImageInfo  

1. Set the Map Model as “Transverse Mercator” and Meters. 
2. Set the projection as EPSG:25835 
Note that the unit vanished from the metadata. When you set the Map Model again, the unit shows 

again. 
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IM-49222 Reprojecting ECW 
image to GDA2020 
Conformal (NTv2) 

datum fails 

Reprojecting an ECW image from EPSG:23855 (GDA94 datum) to the GDA2020 Conformal (NTv2) 
datum takes a very long time (~12 hours) and eventually the process fails. There is no EPSG code 
for the same projection as EPSG:23855 instead using the GDA2020 Conformal (NTv2) datum, so it 

has to be set manually. The projection parameters are outlined below. Reprojecting to the 
EPSG:7855, which is essentially the same projection but using the GDA2020 datum instead of 
GDA2020 Conformal (NTv2), works and only takes a couple of hours.  

 
Steps to reproduce the problem:  
# Start the Reproject Images tool and select the image “ input_image.ecw” as the input file.  

# Enter a name for the output file and make sure the file format is ECW.  
# Set the Processing Option to “Resample to Output File”.  
# Set the Resampling Method to “Nearest Neighbor”.  

# Choose “Rigorous Transformation”.  
# Use the Projection Chooser to set the output map projection using these parameters:  
## Projection Type: UTM  

## Spheroid Name: GRS1980  
## Datum Name: GDA2020 Conformal (NTv2)  
## UTM Zone: 55  

## North or South: South  
## Axis Order: E,N  
# Click OK and wait while it processes and eventually stops. 

IM-37584 Raster attributes 

lost after 
reprojection 

When reprojecting a thematic raster image, the output image does not retain the same raster 

attributes that were included in the input image. 
 
Steps to reproduce the problem: 

Start the Reproject Images tool (Raster tab > Geometry group > Reproject) 
Select the thematic image (with attribute field called “CLC Land Cover”) as the input file. 
Enter a name for the output file. 
Use the default settings in the Reproject tool and click OK to begin reprojecting the data. 

Display the input image in one 2D View and the reprojected image in a separate 2D View. 
Display the raster attribute tables for both images (Table tab > View group > Show Attributes). 
Notice that the column titled “CLC Land Cover” with the class names is missing from the 

reprojected image. 

IM-41736 Image Chain / 
Sensor Look Angle 
is Disabled 

When displaying an image as an Image Chain, the "Sensor Look Angle" option in the lower right 
corner is grayed out. However the Up_is_Up in the Smart Control works.  
The “Sensor Look Angle” option is not grayed out if the image is displayed not using image chains.  

IM-48811 Login to Smart 
M.App link in 

ERDAS IMAGINE 
ribbon is no longer 
functional 

Login to Smart M.App link used in the ERDAS IMAGINE ribbon is no longer functional. The broken 
link opens a page error.  

 
This is due to a change in the address of the Smart M.App marketplace. 

IM-40404 Bubble help for 

Launch Command 
Window button is 
outdated 

Click the Help tab to search for the Session Command History window. It states that that the path is 

Application Menu > Session Options menu, but it is actually File tab > Session > Launch Command 
Window.  
The Application menu is from an older version of ERDAS IMAGINE and is no longer used.  

IM-49188 Ribbon tabs not 
being hidden when 

switching to Spatial 
Modeler through 
title bar 

# Open ERDAS IMAGINE 64-bit  
# Open a raster image in 2D View  

# Open Spatial Modeler  
# switch to the 2D View layer  
# switch to the Spatial Modeler layer by clicking on its title bar (not in the table of contents or inside 

of the layer itself)  
 
Note that the ribbon tabs for the raster image have not been hidden. 
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IM-41512 Confusing error 
message in zonal 
change project 

when regions 
shapefile is locked 

Use two ERDAS IMAGINE sessions in parallel.  
 
ERDAS IMAGINE Session1: 

1) Open regions.shp 
2) On Drawing tab click Enable Editing 
 

ERDAS IMAGINE Session2: 
1) Switch to the Zonal Change Layout and create a new project 
2) Specify Before and After images 

3) Go to Process tab and click Edit Project. 
3) Click Add New Regions > One Per File. Select regions.shp 
 

Get an error message ”The new region is empty. It will not be created”. But it is not empty.  
 
When loading regions.shp via Add New Regions > One Per Polygon the error message is more 

appropriate: 
Spatial Model failed in Features Input. The error  
was "erdas::sb_CGP::VectorSource_X::OnExecute  

failed 
Cannot open specified Vector source". 

IM-39921 Formula does not 
apply to first row of 

vector attribute 
table 

Open an image.  
Open a vector layer over the top.  

On the Drawing tab select Enable Editing.  
On the Table tab, select Show Attributes.  
In the attributes CellArray select a numeric attribut column  

Select, for example, rows 5 to 10.  
Right click on the column titles and select Formula.  
In the Formula dialog type the value 2 and click Apply.  
 

First problem is that you lose the row selection – it should not remove your selection.  
Second problem is that row 5 is still a 1, not a 2. The edit was not applied to the first selected row.  

IM-46339 Large Shapefile 
causes problems 

with viewing vector 
attribute table 

A Shapefile with a lot of records (~1.8 million arcs) causes a problem when scrolling down through 
the vector attribute table. When scrolling to the bottom of the table it bounces back up to the first 

record. The workaround is to right-click in the Record column and select Goto to open the Row 
Position dialog and then click the Last button or enter the desired row number and click Goto. 

IM-46430 Shapefile with a lot 
of arcs (~1.8 
million) causes 

Features Input 
operator error 

A Shapefile with a lot of records (~1.8 million arcs) causes a problem when processing it through 
the Features Input operator. When running the spatial model, it fails at the Features Input operator 
with the message “Read fewer bytes than expected.”  

 
The customer also reports that the Convert To Raster operator fails using the same input Shapefile 
with the error message “The object reference was not set to an object entity". They claim that it 

does work sometimes, but not reliably and if it works, not all of the records are converted to the 
output raster image.  
 

Session log:  
 
SessionMgr(5768): Executing spatial model: c:/steve/convert_to_raster.gmdx  

SessionMgr(5768): Read fewer bytes than expected.  
SessionMgr(5768): Read fewer bytes than expected.  
SessionMgr(5768): ERROR: #2348 from HexGeo::SpatialModeler::Operator::InternalApply  

SessionMgr(5768): ERROR: HexGeo::SpatialModeler::Operator::SetErrorMessage failed  
SessionMgr(5768): ERROR: #1985 from HexGeo::SpatialModeler::Operator::SetErrorMessage  
SessionMgr(5768): ERROR: Spatial Model failed in FeaturesInputCGP.  The error was "Read 

fewer bytes than expected.".  
SessionMgr(5768): ERROR: #2348 from HexGeo::SpatialModeler::Operator::InternalApply  
SessionMgr(5768): ERROR: HexGeo::SpatialModeler::Operator::SetErrorMessage failed  

SessionMgr(5768): ERROR: #1985 from HexGeo::SpatialModeler::Operator::SetErrorMessage  
SessionMgr(5768): ERROR: Spatial Model failed in FeaturesInputCGP.  The error was "Read 
fewer bytes than expected.".  

SessionMgr(5768): Spatial model execution failed. 
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IM-43624 Vector features 
stored in ArcGIS 
Geodatabase with 

units set to degrees 
causes “Units are 
not of same type” 

errors 

A long stream of error messages are displayed when opening vector feature data that has its 
projection units set to decimal degrees and is stored in an ArcGIS Geodatabase. It appears that 
ERDAS IMAGINE does not recognized the map units. The projection is Geographic (Lat/Lon), 

WGS 84, decimal degrees. 
 
The same data exported to a Shapefile does not cause any problems when opening it. Displaying 

the Geodatabase features in ArcGIS does not cause any issues.  

IM-46621 File Chooser does 
not show 
shapefiles for Copy 

Vector Layer, 
Rename Vector 
Layer, and Delete 

Vector layer 

This was only reproducible in 64-bit ERDAS IMAGINE  
 
1) Launch ERDAS IMAGINE > Vector tab > Copy Vector Layer  

2) Observe that both input and output has default *.arcinfo as formats  
3) Now launch input file chooser by clicking open button > go to any location where Shapefiles are 
present 

4) Observe that until the file format is re-selected as Shapefile, the Shapefiles are not visible in the 
file chooser  
5) Next open the output File chooser by clicking open button of Output (note that default output 

format is Shapefile)  
6) Now give an output name and click OK, observe that the output format is *.arcinfo   
7) Unless the output format is re-selected in the file chooser, the output is not produced  

   
Case is same for Rename Vector layer and Delete Vector layer 

IM-45038 ERDAS IMAGINE 
crashes while 
deleting ID attribute 

from vector data 

1.Launch ERDAS IMAGINE  
2.Load a specific Shapefile and display attribute table.  
3.Select the Drawing tab and Enable editing.  

4.Select table tab and click on Column Properties  
5.ID got selected itself on Column Attributes dialog  
6.Click delete and then Ok. Observe ERDAS IMAGINE crashes.  

IM-44889 Zonal Change 
Process failing with 

Image difference 
algorithm 

1.Launch IMAGINE 2018 v 16.5, Launch Zonal Change Layout.  
2.Create a New Project , load input images and Zone files  

Data location:\\alpha\JIRA_data\IM-44888  
* TheVillagesSubset2007.ecw  
* TheVillagesSubset2008.ecw  

* TheVillagesParcelsSubset.shp  
3.After Loading inputs, Select Algorithm as Image Difference and Click Run Region  
4.Let Image Difference Value Parameter Threshold as default Zero and Click ok observe that 

process failing.  
>> Session log attached for reference.  
 

NOTE: 
* The same workflow is not giving an indication of process failing in IMAGINE 32 bit.  
* The same workflow if tried with same raster input for both Before image and After image (EX: 

TheVillagesSubset2007.ecw) to make input image difference as zero, again also process failing, 
which should be theoretically wrong for end user.  
* Not giving user friendly pop-up message that Image difference threshold should not be Zero 

IM-17921 Not replacing an 

not-existent Before 
image or After 
image caused 

IMAGINE crash 

Take any projects from here 

\\alpha\teamspace\Pixel\Temp\ZCim14diff 
 
Open the project 

It tells you files are missing and to correct the path. 
If you do not select the right img file (by clicking Cancel, for instance), IMAGINE would crash.  
If you select the right img file and press substitute, error is thrown that shapefile link is incorrect and 

the project does not open. 

IM-37622 Zonal Mean 

produces incorrect 
result (1.#QNAN) 
with float class 

raster (and NoData 
set to 0) 

See model copied to \\alpha\Siebel_Bug_Data\1-KZ8EUF. It’s basically takes a shapefile as raster 

as the Zones, a floating point image as the Class Raster and feeds them into Zonal Mean. 
 
Run the model once and note that the mean is stated as 1.#QNAN 
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IM-49444 With only Before or 
After Image in the 
Zonal Change 

Layout, closing it 
with/without saving 
crashes ERDAS 

IMAGINE 

1) Launch IMAGINE > File > Layout > Zonal Change Layout  
2) Process tab > New > create a new project C:\temp\example.zcp  
3) Add only Before or After Image in the 2D Viewer, click Close in the Process tab, click Yes/No 

  
Observe that it crashes ERDAS IMAGINE while trying to close the Zonal Change layout with only 
Before or After Image in the layout  

   
Note:  
1) If both Before and After images are loaded in the Zonal Change Layout and the Zonal Change 

layout is closed no crash is observed.  
2) This is not reproducible in ERDAS IMAGINE 2016  

IM-36621 Selecting Help tab 
> ERDAS 

IMAGINE Release 
Guide & 
HexGeoWiki, 

throws ewinopen 
crash dialog 

Goto Help tab > select ERDAS IMAGINE Release Guide. Dialog opens stating, ewinopen has 
stopped working.  

Goto Help tab > select Reference Book > HexGeoWiki. Dialog opens stating, ewinopen has 
stopped working. 

IM-33825 Image recode is 
not working from 
Raster tab > 

Thematic > Recode 

1.Launch ERDAS IMAGINE, Load the Image landcover_cherokee.img 
2.Select Recode from Raster tab > Thematic > Recode. 
3.Recode dialog opens,click Setup Recode 

4.Change the value of water-1 ,Coniferous Forest-2,Mixed Forest-2,Deciduous Forest-2 and 
remaining all -0 and click Ok  
5.Provide the output File name and click OK and observe process failing with an error out of the 

Range LUT  
 
NOTE: The same work flow from Thematic tab > Recode producing output without any issues. 

IM-22019 BigTIFF gives error 
messages when 

displaying in 
ERDAS IMAGINE 

BigTIFF created by Intergraph ISIS does not display in ERDAS IMAGINE, but does in other GIS 
products. While the file extention is .btf, the TIFF DLL searches the file, determines it is a BigTIFF, 

and then gives multiple errors.  
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IM-43993 Error when creating 
RSETs for large 
Float IMG file 

Make a local copy of the large (>2GB) .img and .ige files (only)  
Start Spatial Model Editor  
Start the Session Log  

Add a Generate RSETs operator  
Set the copy of the .img file as the input filename.  
Click Run  

 
.r1 seems to generate OK, but then you start seeing these messages in the Session Log:  
28/03/18 12:18:37 SessionMgr(816): Connection success for the external process 'eWkspace_64'  

28/03/18 12:19:14 SessionMgr(816): Executing spatial model  
28/03/18 12:20:28 SessionMgr(816): ERROR: #22879 from eimg::details::SSLayerGetNames  
28/03/18 12:20:28 SessionMgr(816): ERROR: <NULL> failed  

28/03/18 12:20:28 SessionMgr(816): ERROR: #67 from <NULL>  
28/03/18 12:20:28 SessionMgr(816): ERROR: eimg_FileImageNamesGet failed  
28/03/18 12:20:28 SessionMgr(816): ERROR: #14930 from eimg_FileImageNamesGet  

28/03/18 12:20:28 SessionMgr(816): ERROR: eimg_FileOpen failed  
28/03/18 12:20:28 SessionMgr(816): ERROR: #5968 from eimg_FileOpen  
28/03/18 12:20:28 SessionMgr(816): ERROR: h:/temp/super-stack_4-dates.img.r2: eimg_FileOpen 

failed (33:Unsupported Raster format or non-Raster format)  
28/03/18 12:20:52 SessionMgr(816): ERROR: #22879 from eimg::details::SSLayerGetNames  
28/03/18 12:20:52 SessionMgr(816): ERROR: <NULL> failed  

28/03/18 12:20:52 SessionMgr(816): ERROR: #67 from <NULL>  
28/03/18 12:20:52 SessionMgr(816): ERROR: eimg_FileImageNamesGet failed  
28/03/18 12:20:52 SessionMgr(816): ERROR: #14930 from eimg_FileImageNamesGet  

28/03/18 12:20:52 SessionMgr(816): ERROR: eimg_FileOpen failed  
28/03/18 12:20:52 SessionMgr(816): ERROR: #5968 from eimg_FileOpen  
28/03/18 12:20:52 SessionMgr(816): ERROR: h:/temp/super-stack_4-dates.img.r3: eimg_FileOpen 

failed (33:Unsupported Raster format or non-Raster format)  
28/03/18 12:20:59 SessionMgr(816): ERROR: #22879 from eimg::details::SSLayerGetNames  
28/03/18 12:20:59 SessionMgr(816): ERROR: <NULL> failed  

28/03/18 12:20:59 SessionMgr(816): ERROR: #67 from <NULL>  
28/03/18 12:20:59 SessionMgr(816): ERROR: eimg_FileImageNamesGet failed  
28/03/18 12:20:59 SessionMgr(816): ERROR: #14930 from eimg_FileImageNamesGet  

28/03/18 12:20:59 SessionMgr(816): ERROR: eimg_FileOpen failed  
28/03/18 12:20:59 SessionMgr(816): ERROR: #5968 from eimg_FileOpen  
28/03/18 12:20:59 SessionMgr(816): ERROR: h:/temp/super-stack_4-dates.img.r4: eimg_FileOpen 

failed (33:Unsupported Raster format or non-Raster format)  
28/03/18 12:21:03 SessionMgr(816): Spatial model execution complete.  
   

The RSETs do seem to be created (and used) correctly. 

IM-36660 Image Chain 

stretch panel 
enhancement not 
correctly 

responding by 
entering values 
from keyboard 

1.Open Raster image (16-bit Multispectral) as Image chain data 

2. Launch Stretch panel, change the type to Two Point Linear. 
3. Change the Gray Max to 400 by entering from Keyboard and click enter. 
Observe that image changes to white. But when the same value is adjusted through moving the 

slider the colour changes as expected. 

IM-36198 CGCF-ECW and 

CCGF-JP2 Not 
Persisting GeoTIFF 
Tag Correctly 

Creatable Grid Covergage Fromat (CGCF) ECW and CCGF JP2 Not Persisting GeoTIFF Tag 

Correctly 
 
GeoTIFF tags are not persisted as "2240" as is found in the source TIFF. Rather, they are 

persisted as "Unknown-2240".  
This test was done using the "Save As" Viewer capability in ERDAS IMAGINE 2016 v16.1 
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IM-22018 CellArray with large 
number of rows is 
wrong when 

scrolled to bottom 

Start Raster Attribute Editor on Segmentation or Clump output with upwards of 400,000 classes. 
Scroll to bottom - you see the first few rows instead of the last few rows.  
Resize the dialog to make it taller (or enlarge docked panel within the ribbon). 

Try again - it now works OK. Shrink the dialog back - the problem reappears. 
 
For larger CellArrays (a million rows) the resizing trick does not work. This makes it virtually 

impossible to see the last rows of the table. 
 
Use RasterToVector to create arc coverage with same amount of records. View coverage and view 

vector attributes - has similar problems. 
 
This affects all CellArrays in ERDAS IMAGINE when dealing with a long list. 

IM-11221 ERDAS IMAGINE 

not recognizing 
Hebrew characters 
in the folder name 

ERDAS IMAGINE 2013 and 2014 are not recognizing any files in the folder when the folder name 

is written in Hebrew character  
 
 

IM-20577 GeoEye TIFF 
image without 

GTRasterTypeGeo
Key tag delivers 
many repeat errors 

When reading the GTRasterTypeGeoKey tag from a GeoEye TIFF image, the session log posts the 
following message 13 times:  

 
eWkspace(1724): ***WARNING NUMBER 1758 IN FUNCTION GeoTIFFGeoreferencingGet***  
eWkspace(1724): >>>Cannot locate GTRasterTypeGeoKey; assuming RasterPixelIsArea<<< 

IM-35798 ERDAS IMAGINE 

crashes on 
pressing Enter Key 
from keyboard after 

clicking on File > 
New white space 

Launch ERDAS IMAGINE  

Select File > New 
Click on the White space below 2D View #1 New Options  
Press Enter Key 

Observe that ERDAS IMAGINE crashes 
 

IM-20588 Spatial Profile tool 
crashes when 
trying to calculate a 

second line of sight 
profile 

Observed while performing tests to validate a M.App X geoprocessing service. 
 
Display a DEM  

Fit to Frame. 
On the Panchromatic tab select Spatial Profile. 
Say OK to the warning that no vector layers are displayed. 

Draw a line corner to corner of the DEM. 
Observe that a profile is drawn. 
In the Spatial Profile tool click the Edit menu and select Overlay Sight. 

Specify the height off the ground as 6 feet and click Apply. 
Observe that line of sight is calculated and overlaid onto the profile. 
Leave the Line of Sight overlaid. 

Select the digitise polyline tool and draw a new profile line (shorter than the original if you want). 
Observe that memory usage gradually goes up to 4GB and the profile tool eventually crashes (after 
several minutes). 

 
16/03/15 09:58:56 SessionMgr(7376): advprofile.exe exited with status -1073741819. 
 

Instead, if Sight overlay was turned off before creating the new line, it would have worked fine. 

IM-19745 TIFF DLL not 

handling multi-page 
TIFFs correctly 

ERDAS IMAGINE 2013 correctly handled multi-page TIFFs.  

 
In ERDAS IMAGINE 2014, a regression crept in where only the first page of the TIFF can be 
displayed. All the pages in the TIFF can be seen in the Multi-Image tab, and all of the pages can be 

selected as sub-images, but the selected TIFF page is not displayed. Rather, the first page is 
displayed. 

IM-21166 Alone Algorithm 
File Crashes 

ERDAS IMAGINE 

Sequence to Reproduce: 
(1) Install ERDAS IMAGINE 2015, but do not include ER Mapper 

(2) Copy <IMAGINE_HOME>/examples/ermapper/miscellaneous/test_patterns/HSI_Wheel.alg to a 
folder on the local disk. (Do not copy the Demo_wheel.* files). 
(3) Open / Algorithm on the copy of the ALG file 

ERDAS IMAGINE terminates abnormally.  
It does not terminate if you copy the Demo_wheel files. 
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IM-13358 ERS DLL does not 
use ECW file 
referenced in ERS 

Header correctly 

ERS DLL does not use ECW file referenced in ERS Header correctly.  
 
Add the two ERS header files referencing ECW files to MosaicPro 

Run the mosaic to a .ecw file 
 
A message appears once the process begins: ERS Raster error: Filetype Unknown error message 

when mosaicking .ers files. Mosaic slowly completes.  
 
Session Log:  

02/12/13 10:01:47 C:/Program Files/Intergraph/ERDAS IMAGINE 
2014/bin/x64URelease/mosaicprocesspro.exe -m c:/temp/mosaic_tmp_mos_008780 -temporary -
background 0 -ignore 0 -excludeempty 0 -meter mosaic 

02/12/13 10:01:56 SessionMgr(6056): ERROR: #46 from ersFileTitleIdentifyAndOpen 
02/12/13 10:01:56 SessionMgr(6056): ERROR: erdas::ers::FileHandle::DoOpen failed 
02/12/13 10:01:56 SessionMgr(6056): ERROR: #95 from erdas::ers::FileHandle::DoOpen 

02/12/13 10:01:56 SessionMgr(6056): ERROR: ERS Raster error: Filetype unknown 
02/12/13 10:01:58 mosaicprocesspro(4312): One or more input files or output files cannot be 
opened by 64 bit MosaicProcessPro. Starting in 32 bit. 

02/12/13 10:01:58 C:/Program Files/Intergraph/ERDAS IMAGINE 
2014/bin/Win32Release/mosaicprocesspro.exe -m c:/temp/mosaic_tmp_mos_008780 -temporary -
background 0 -ignore 0 -excludeempty 0 -meter mosaic  

IM-18862 Opening ERS file 

gives incorrect 
NODATA message 
in Session Log 

Launch ERDAS IMAGINE. 

In 2D View, open an ERDAS ER Mapper (*.ers) file,  
In Session log, see “16/12/14 08:33:25 eWkspace(14248): The input NullCell Value is out of range 
for the current pixel type 

16/12/14 08:33:25 eWkspace(14248): The input NullCell Value is out of range for the current pixel 
type…....” 

IM-20601 Computing 
pyramids on a 
Virtual Mosaic 

(VMCX) pointing to 
15k by 5k PNG 
throws a series of 

errors 

Computing RRDs on a VMCX pointing to 15k by 5k PNG throws a series of errors. 
In Image Metadata, open the VMCS file and compute Pyramids. 
ERDAS IMAGINE throws a series of errors.  

After some time, Image Metadata crashes.  
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IMAGINE Advantage 

Issue ID Summary – IMAGINE 

Advantage 

Description / How to Reproduce 

IM-22547 Incorrect and inconsistent 

output parameters for 
orthorectification in both 
ERDAS IMAGINE and 

IMAGINE Photogrammetry 

In trying to create Operators for Spatial Model for orthorectification we needed to look at 

the default behavior for orthorectification of calibrated images.  
 
Generally, when rectifying or reprojecting an image you want the default settings to 

never result in a loss of pixel information. Obviously this cannot be eradicated entirely 
(except by gross oversampling), but you want to generally produce an output image 
where few pixels have been dropped out from the input image. 

 
A rough measure of this is that no matter how rotated or warped the model is, the 
output would generally have to have more pixels than the input in order to preserve 

every input pixel. 
 
Unfortunately not only do the ERDAS IMAGINE output defaults often not meet this 

requirement, they are also frequently inconsistent between the numerous approaches 
you can take to producing a transformed output image. We need to be both consistent 
and correct. 

 
See specific NITF sample image 
Open the image in a 2D View. 

Click Image Metadata and note that the image is 8820 columns x 4696 rows.  
 
Scenario1: 

Multispectral tab / Transform & Ortho tab / Transform & Ortho menu, select Ortho Using 
Existing Model. 
Note in the dialog that the output image defaults to having only 6599 columns x 6278 

rows. 
Given the nature of this image’s geometric model, which is a “shear” into a 
parallelogram shape, the reduction in columns means that 1/3rd of the original image 

pixels will be missing from the output. Go ahead and produce the output and take a look 
at it – it has a degraded appearance. 
 

Scenario2: 
Multispectral tab / Transform & Ortho tab / Transform & Ortho menu, select Reproject. 
Set to Geographic / WGS84, which is the same as Scenario1. 

Note strange default pixel dimensions. 
Produce the output – note that this one is 8820 columns x 4696 rows – same as the 
input. 

IM-33588 Horrendous edge artifacts 

introduced with Bicubic 
resampling 

See data geometrically calibrated using RPCs. 

On the Multispectral tab / Transform & Ortho / Ortho Using Existing Model. 
In the Resample dialog, specify square pixels, ignore 0 in stats, use Elevation Library 
and set resampling to Bilinear. 

Specify output filename and OK. 
Display results in a 2D View with background set to red. 
Observe perfectly crisp left-hand edge of the image. 
 

Now repeat, but this time select Bicubic resampling. 
Observe nasty edge artifacts of near-black introduced around the edges of the data. 

IM-41647 Condor processes using 32-
bit Batch process for the 

jobs submitted from 64-bit 
ERDAS IMAGINE 

From Submitting node, Distributed processing is started using Batch Command Editor 
of ERDAS IMAGINE 64-bit.  

On the Processing node, the job is processed using 32-bit Batch process instead of 64-
bit Batchprocess.  

IM-22790 MosaicPro should default to 
Bilinear when resampling 
must occur 

MosaicPro should default to Bilinear when resampling must occur to ensure the best 
quality image by default. By default Nearest Neighbor is used and creates blocky and 
lower quality data than MosaicPro can deliver. 

 
Several other tools default to Bilinear when resampling is needed. MosaicPro should 
follow the move to better default data output. 
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IM-46606 Adding images with “Active 
Areas by Corners” is 
generating very bad output, 

whereas the “Active Area by 
Edges” is giving good output 

Customer reported that in MosaicPro by adding images with “Active Areas by Corners” 
is generating very bad output, whereas the “Active Area by Edges” is giving good 
output. 

 
“Active Areas by Corners” was occasionally mis-identifying corners thereby clipping too 
much from the input data. 

IM-25246 MosaicPro: sometimes 

leaves holes when creating 
specific dataset 

Occasionally Seamlines in MosaicPro would result in small (1 pixel) gaps in the output 

mosaic 

IM-45744 Reset button not working as 
expected in MosaicPro > 
Adjust individual image 

radiometry 

1.Launch ERDAS IMAGINE, Launch MosaicPro from Raster tab > Geometry  
2.Add images, make them visible and select from table  
3.Click Adjust individual image radiometry, Change the brightness by dragging 

Brightness bar  
4.Click Reset Button and observe Brightness bar reverting to original state but image 
still persist with brightness change.  

 
NOTE: Instead of reset button at the bottom if we click the reset brightness beside the 
brightness bar image reverting to original state. 

IM-43093 Mosaic Express does not 

include Lagrange 
resampling method 

Mosaic Express does not include Lagrange resampling method 

IM-44279 MosaicPro Workstation 
crashed when opening a 
specific project 

In some instances, where input images overlap each other almost 100%, crashes could 
occur. 

IM-44912 Some input image is 

missing in mosaicking 
output 

There are only two input images, the left and the right. They look good in MosaicPro 

workstation. However, the left is missing in the output file.  

IM-48504 Toggling raster display after 
editing seam polygon 
crashes MosaicPro 

Launch ERDAS IMAGINE 2018 
Open MosaicPro, load two overlapping airphotos.  
Make the images visible and display the rasters.  

Click ‘Automatically generate seamlines for intersections’ button and in ‘Seamline 
generation options’ dialog, click ok.  
Click ‘Edit seam polygons’ and draw a polygon at the intersection. Observe seam 

polygon is edited.  
Now click ‘Display raster images’ and observe MosaicPro crashes.  

IM-46883 running 
mosaicprocesspro.exe from 
Command window ignores 

TIFF compression 
parameter 

When running mosaicprocesspro.exe from the Command window, the TIFF 
compression argument is ignored. The compression setting from the TIFF preferences 
is used instead. The help documentation for mosaicprocesspro states that “If you do not 

specify this option when the output is a TIFF image, the compression type specified in 
the TIFF preferences is used.”  
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IMAGINE Objective 

Issue ID Summary – IMAGINE 

Objective 

Description / How to Reproduce 

IM-39533 Running FLS Segmentation 

crashed fe_process 

Specific data would cause FLS Segmentation to run out of memory and crash. 

 

IMAGINE Photogrammetry 

Issue ID Summary – IMAGINE 
Photogrammetry 

Description / How to Reproduce 

IM-47032 IMAGINE Photogrammetry 
ATE Report cannot be 

loaded using the Ribbon 
function 

After a successful ATE run it is actually not possible to load the ATE Report by 
activating the Photogrammetry ribbon function “Reports/Automatic Terrain Extraction 

(ATE) Report”. It seems that the blockfile name and the blockfile path are not saved 
properly when executing ATE (see line 8 and 9 of the ATE reportfile). 
 
Error messages and warnings reported in the session log: 

18/12/18 14:16:30 SessionMgr(7256): ERROR: #2277 from StartATEReport 
18/12/18 14:16:30 SessionMgr(7256): ERROR: eatm_DTMExtractionReport Failed 
18/12/18 14:16:30 SessionMgr(7256): WARNING: #598 from 

eatm_DTMExtractionReport 
18/12/18 14:16:30 SessionMgr(7256): WARNING: No valid report file exists 
18/12/18 14:16:40 SessionMgr(7256): ERROR: #2277 from StartATEReport 

18/12/18 14:16:40 SessionMgr(7256): ERROR: eatm_DTMExtractionReport Failed 
18/12/18 14:16:40 SessionMgr(7256): WARNING: #598 from 
eatm_DTMExtractionReport 

18/12/18 14:16:40 SessionMgr(7256): WARNING: No valid report file exists 

IM-46924 3D ASCII output from 
Create Mean Terrain has 
characters for space making 

the output not useful 

* Launch ERDAS IMAGINE 2018 64-bit.  
* Open a blockfile in the viewer.  
* From the Photogrammetry tab, under Generate drop down menu, click Create Mean 

Terrain.  
* In the Create Mean Terrain dialog, select 3D ASCII as Output DTM Type.  
* Give the name of the output and click OK in the dialog.  

 
Open the output in a text editor and notice that there are characters for spaces in the 
file. This makes the file not useable in any other tools like Surfacing tool. 

IM-44828 Unable to import a project 
into IMAGINE 
Photogrammetry 

1.Launch ERDAS IMAGINE 2018 
2.Load any block file 
3.Launch Import Inpho project from Photogrammetry Tab > Conversion group  

4.Try to import InphoProject file of Type .prj , observe that you are not able to import as 
block file loaded in the input file field and trying to load .prj from file chooser is not 
showing the file in the respective folder 

IM-48674 Unable to open SPOT-7 
DIMAP V2 (DIM_SPOT.xml) 
projected (PRJ) raster data 

SPOT-7 DIMAP V2 projected (PRJ) PMS data fails to open in ERDAS IMAGINE 2018 
 
Launch ERDAS IMAGINE 2018  

Right-click > Open Raster  
from the file chooser > Files of type  
select > SPOT DIMAP V2  

choose DIM file DIM_SPOT7_PMS_*_PRJ_*.XML  
Error message appears. “Unknown DIMAP format” 
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IM-47013 No footprints when loading a 
block file with offline terrain 
file 

A specific .blk adjusted in ERDAS IMAGINE 2016 can be open as expected in the LPS 
Project Manager, with footprints, etc. displayed.  
 

But if opened as a photogrammetric project, in ERDAS IMAGINE 2016 or 2018, only 
the CellArray displays, the footprints do not. And when you fit to frame or zoom out an 
error message displays. 

 
This is caused by an offline LTF file under the Terrains folder. Once you remove it, the 
error message is gone. 

IM-48409 Block files created with an 

older version (ERDAS 
IMAGINE 2016 and earlier) 
are not compatible with 

IMAGINE Photogrammetry 
2018 

Block files created with an older version (2016 and earlier) are not compatible with 

IMAGINE Photogrammetry 2018 for the purpose of making orthophotos. 
Orthorectification with 2018 fails, generates corrupted image. 
Data is TiFF aerial RCD30 data. 

IM-47866 IMAGINE Photogrammetry 
Orthoresample error with 

ADS L1 blk project 

Orthoresample function with ADS L1 blk project fails with ERDAS IMAGINE 2018 
Update 2. If you attempt to orthorectify L1 imagery you get a “Failed to recognize 

Authority Code” error. 
 

IM-46599 Under Photogrammetry tab, 
Import ISAT, Inpho, PATB 
and SS project is not 

showing up the input files 
unless the format in the 
Import window is re-selected 

1) Launch ERDAS IMAGINE -> Open any block file   
2) Under Photogrammetry tab -> Import ISAT Project  
3) In the Import window click open for Input File and browse to a location with ISAT 

Project files 
 
Observe that the ISAT project icon is not shown. 

Also for other 3 formats Inpho project, SS project and PATB project also the case is 
same, that is, the respective format files do not show. But if Format is re-selected in the 
Import window, then the input files do show.  

IM-41918 Deleted points in .las are 

still there after exporting to 
HPC file 

Several point clouds in LAS format were edited in IMAGINE Professional to remove 

incorrect elevation points. 
The resulting LAS were now used in GeoMedia 3D using the HPC Point Clouds 
workflow to Construct a HPC and then insert the resulting HPC into an access 

warehouse, The two processes ran with no error. 
The HPC is now displayed in GeoMedia 3D. The points previously edited in ERDAS 
IMAGINE are still there. 

IM-45013 Height Above Ground tool 
does not preview and 

throws error message 

ERDAS IMAGINE 2018 
 

1) Launch ERDAS IMAGINE > Terrain tab > Height Above Ground   
2) Provide a classified LAS file as input   
3) Give input raster elevation file  

4) Give output name  
5) Click Preview button   
 

Observe that it throws this error saying: No PreviewOperators in model.  
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IM-46256 Errors pop up if a file from 
recent list is opened on top 
of a point cloud preview 

Data: GMDX, LAS, SHP and IMG files of the same project area  
 
Steps to reproduce: 

* Open the LAS, SHP and IMG files in the 2D View.  
* Clear the View and launch Spatial Modeler Editor.  
* Open a gmdx file and give the LAS file from the project as input to the Point Cloud 

Input operator.  
* Click on Preview.  
* Once the preview is up and the Preview View selected, from the Point Cloud tab 

select Classification in the Color by drop down menu.   
* From File > Recent select either the SHP or IMG file that were previously opened in 
the 2D View.  

Notice that error pop up. 
 
Session log: 

26/09/18 14:38:44 SessionMgr(26760): ERROR: #124 from ArrangeLayersCB  
26/09/18 14:38:44 SessionMgr(26760): ERROR: 
erdas::EmlFramework::ShellMeter::Create failed  

26/09/18 14:38:44 SessionMgr(26760): ERROR: #56 from 
erdas::EmlFramework::ShellMeter::Create  
26/09/18 14:38:44 SessionMgr(26760): ERROR: Trying to change a running meter from 

modal to non-modal is not supported! 

IM-40464 Loading a specific LAZ file 
as Raster crashes ERDAS 
IMAGINE 

1.Launch ERDAS IMAGINE 2018  
2.Load the file specific .laz ,by selecting files of type as LAZ as Raster (.laz) ( not LAZ 
as Point Cloud (*las) )  

3.Observe ERDAS IMAGINE crashes.  
 
When the same file is opened as  LAZ as Point Cloud(.las), ERDAS IMAGINE does not 
crash  

IM-49425 ERDAS IMAGINE 2018 

Update 2 is unable to open 
customer’s *.las file 

Customer reported that ERDAS IMAGINE is unable to open their las and laz files. 

According to the customer the same las file opens in a popular GIS application. 
 
In ERDAS IMAGINE the following error messages show in the session log, while 

opening the customer’s las in a 2D View 
 
24/06/19 00:30:42 SessionMgr(12944): Connection success for the external process 

‘eWkspace_64’ 
24/06/19 00:31:27 SessionMgr(12944): ERROR: #192 from vr_lidarvlLayerOpen 
24/06/19 00:31:27 SessionMgr(12944): ERROR: erdas::laslib::GenericVlr::Read failed 

24/06/19 00:31:27 SessionMgr(12944): ERROR: #228 from 
erdas::laslib::GenericVlr::Read 
24/06/19 00:31:27 SessionMgr(12944): ERROR: emif_ConvertToMIF failed 

24/06/19 00:31:27 SessionMgr(12944): ERROR: #6148 from emif_ConvertToMIF 
24/06/19 00:31:27 SessionMgr(12944): ERROR: emif_MIFtoObject failed 
24/06/19 00:31:27 SessionMgr(12944): ERROR: #6207 from emif_MIFtoObject 

24/06/19 00:31:27 SessionMgr(12944): ERROR: Invalid object or design! 

IM-47189 ERDAS IMAGINE crashes 

with point cloud polyline 
profile 

1.Launch ERDAS IMAGINE  

2.Load a point cloud image, Select point cloud Tab  
3.From Profile group, select Polyline Profile  
4.Draw a polyline and end it by single mouse click and double click Left Mouse button 

at the exact same point  
5.Observe ERDAS IMAGINE crashes. 
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IM-45910 ERDAS IMAGINE 32-bit 
crashes while trying to pan 
in the HPC file’s profile 

views after zoom is 
performed 

* Launch ERDAS IMAGINE 2018 32-bit and load a HPC file.  
* From the Profile group of Point Cloud tab, click the Rectangle Profile option and draw 
a rectangle in the viewer.  

* In either the Sideview Profile viewer or the Frontview Profile viewer, zoom in and then 
pan using either the middle mouse button or the pan tool from the Home tab.  
 

Notice that ERDAS IMAGINE crashes. 
 
ERDAS IMAGINE 2018 64-bit doesn’t crash but only shows up error while panning. 

 
Session log: 
_31/08/18 15:16:56 SessionMgr(3096): ERROR: #4 from 

EFGA_DERIVEPOLYCOEFS_  
_31/08/18 15:16:56 SessionMgr(3096): ERROR: EFGA_SOLVELINEAREQS failed_  
_31/08/18 15:16:56 SessionMgr(3096): ERROR: #4 from EFGA_SOLVELINEAREQS_  

_31/08/18 15:16:56 SessionMgr(3096): ERROR: egda_MatrixDivide failed_  
_31/08/18 15:16:56 SessionMgr(3096): ERROR: #6 from egda_MatrixDivide_  
_31/08/18 15:16:56 SessionMgr(3096): ERROR: egda_MatrixDivideF64 failed_  

_31/08/18 15:16:56 SessionMgr(3096): ERROR: #2 from egda_MatrixDivideF64_  
_31/08/18 15:16:56 SessionMgr(3096): ERROR: egda_MatrixLUDecomposition failed_  
_31/08/18 15:16:56 SessionMgr(3096): ERROR: #7 from 

egda_MatrixLUDecomposition_  
_31/08/18 15:16:56 SessionMgr(3096): ERROR: egda_MatrixLUDecompositionF64 
failed_  

_31/08/18 15:16:56 SessionMgr(3096): ERROR: #1 from 
egda_MatrixLUDecompositionF64_  
_31/08/18 15:16:56 SessionMgr(3096): 

IM-45741 While Exporting to ISAT 
project for which sensor 

models are Unsupported, 
the exportisat.exe process 
crashes 

# Launch ERDAS IMAGINE 
# File > New > Photogrammetric Project and give the path of the Block fie to be saved  

# Select *Rational Functions* for Geometric Model Category and *Quickbird* *RPC* for 
Geometric Model on Model Setup dialog and Click OK  
# Leave the default settings on Block Property Setup dialog and Click OK  

# Now add NITF format QuickBird images to the block file 
# Save the Block file and go to Conversion group > *Export to ISAT Project*  
# Provide output project name and Hit OK  

# Observe that the exportisat.exe crashes while exporting to ISAT project  
  
Note: Similar is the observation for Formosat2 orbital pushbroom model, Triplesat RPC  

IM-43782 Failure at the end of the 

process due to tridicon 
intermediate files limitation 

To produce a DSM with 6 granules of satellite images, customer uses the Semi-Global 

Matching (SGM) tool. The first step of SGM is to calculate Tridicon Intermediate files for 
each pair of images. If a Tridicon intermediate file generated is bigger than 4GB, 
ERDAS IMAGINE returns an error and stop the process (since the Tridicon software 

does not support BigTIFF). 
 
If possible please compute output intermediate image size in advance, for example 

displaying a warning to prevent having to wait until at the end of the process before it 
fails. 

IM-48126 ERDAS IMAGINE crashes 
while trying to get the report 
after changing the Remove 

Points over n Standard 
Deviations value multiple 
times 

ERDAS IMAGINE 2018 Update 2  64-bit  
1) Launch ERDAS IMAGINE > Load a specific Block File > Launch Stereo Point 
Measurement (SPM)  

2) Under SPM > Tools > launch Tie Point Uncertainty Analysis   
3) Change the value of Remove Points over n Standard Deviations to 0 and Apply > 
Click Report > Observe that Report launches  

4) Now again Change the value of Remove Points over n Standard Deviations to 0 and 
Apply > Click Report and again repeat the same step  
   

Observe that ERDAS IMAGINE crashes while trying to get the report after changing the 
value of Remove Points over n Standard Deviations multiple times. 
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IM-47477 Under Stereo Point 
Measurement (SPM) 
Viewing Properties in Image 

Correlation texts are not 
properly visible for 
Correlation Contrast 

1) Launch ERDAS IMAGINE > File > Open > Photogrammetric Project > open a 
specific Block project  
2) Launch Stereo Point Measurement Tool from Point Measurement dropdown menu  

3) In SPM under Tools Menu launch Viewing Properties, select Image Correlation tab  
   
Observe that the Text for 'Low' and 'High' are not visible properly 

 

 

IMAGINE Professional 

Issue ID Summary – IMAGINE 
Professional 

Description / How to Reproduce 

IM-20641 Every so often an ECW 

in a batch list fails to 
calculate stats 

Running a batch statistics/histogram calculation (32-bit application) with a total of more than 

5000 ECWs; running 3 jobs in parallel. Each image is 4000 x 4000 x 3bands x ECW v2.  
 
Every so often, an ECW fails to calculate stats. Locate the ECW, open it in the Viewer, it 

displays fine and is visually fine. Open the ECW in Image Metadata, it looks fine. Calculate 
stats, and the process completes fine.  
 

Failure in Session log states: imagecommand.exe exited with status -1073741819.  

IM-45743 Number of output files 

produced is not the 
same as number of 
inputs provided in Batch, 

Start Processing Later 
At 

1.Launch Unsupervised Classification from Raster tab > Classification > Unsupervised  

2.Provide the input file, specify output file, provide required number of classes and click on 
Batch  
3.Now select variables as one input, one or more outputs  

4.Add three more files, click on submit , select Start Processing Later At  
5.Provide Simultaneous Processes as 4 and click OK  
6.Provide the proper credentials and click Ok  

7.Scheduled batch process listed and process become active at start time and done after a 
while.  
8.Observe the output folder. The outputs produced are one or two files, rather than the 

expected four. This is not the case with Batch > Start Processing Now 

IM-36818 Spatial Modeler batch 
command file (.bcf) is 
not saved from the 

Batch Command Editor 

Spatial Modeler batch command file (.bcf) is not saved from the Batch Command Editor 
when accepting the default batch command name after clicking OK  
 

To recreate:  
- Open Spatial Model 
- select Run in Batch (opens the Batch Command Editor)  

- select Save. The Batch Command file chooser opens with the temp batch filename.  
- select OK.  
The batch command file is not saved in the default temp location  
 

If you manually add the .bcf extension, the batch command file is saved.  
If you change the name, the batch command file is saved.  
If you redirect to a different folder, the batch command file is saved.  

If you click <Enter> instead of OK, the file is saved.  
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IM-8447 Spectral Euclidean 
Distance value 
continues to change 

when clicking other 
areas than the nudgers 

In the Region Growing Properties tool, the Spectral Euclidean Distance nudger is “sticking” 
when changing the value and then proceeding to grow regions in the 2D View. The Spectral 
Euclidean Distance value continues to be adjusted even though the mouse clicks are 

elsewhere in the ERDAS IMAGINE interface. 
 
This problem does not occur in ERDAS IMAGINE 2011. The Region Growing Properties 

dialog did not have a thumbwheel for adjusting the Spectral Euclidean Distance in 2011, so 
maybe that is contributing to the problem.  
 

Steps to reproduce: 
Display the raster file lanier.img in a 2D View. 
Open the Region Growing Properties tool (Drawing tab > Insert Geometry group > Grow 

menu > Growing Properties). 
Click the Grow icon (Drawing tab > Insert Geometry group > Grow) to place a seed pixel in 
an area of water. 

Click on the up nudger a couple of times to increase the Spectral Euclidean Distance value.  
Now click on an empty area in the Region Growing Properties tool and notice that the 
Spectral Euclidean Distance value continues to change and the polygon region in the 2D 

View continues to grow to reflect the change of the Spectral Euclidean Distance value. 
Even if you click elsewhere in the ERDAS IMAGINE interface, the Region Growing 
Properties tool remains active and the Spectral Euclidean Distance value continues to 

change. 

IM-45028 Image Alarm crashes 
64-bit version of ERDAS 
IMAGINE 2018 

Image Alarm tool crashes ERDAS IMAGINE 2018 64-bit. Session log reports “Unusual file 
mapping size 264248”. The 32-bit versions of ERDAS IMAGINE 2018 and ERDAS 
IMAGINE 2016 Update 1 do not crash when using this tool.  

 
Steps to reproduce: 
# Display Multispectral image in a 2D View  
# Start the Signature Editor. (Raster tab > Classification group > Supervised menu > 

Signature Editor).  
# Open a signature file derived from the Multispectral image.  
# Re-associate the signature file and the image. (Signature Editor > Edit menu > Image 

Association)  
# Select one of the rows in the Signature Editor.  
# Start the Signature Alarm tool. (Signature Editor > View menu > Image Alarm) and click 

OK.  
# Click inside the 2D View.  
# ERDAS IMAGINE 2018 crashes. 

IM-47545 Unsupervised 

classification generates 
output with a missing 
block of data 

Unsupervised classification generates output with a missing block of data.  

Failure appears be related to the number of classes to be created and to the output file type 
(i.e. TIFF). A specific lower and upper range fails when writing TIFF output. Using this same 
range works when writing IMG output. Specifying a different number of output classes 

works when writing TIFF output.  
 
If the input TIFF file is converted to IMG and used as input, the problem is not seen.  

 
These errors are seen when the failure occurs  
06/02/19 11:37:39 SessionMgr(14936): etif_HandleBlockRead failed  

06/02/19 11:37:39 SessionMgr(14936): etif_HandleBlockRead failed  
06/02/19 11:37:39 classifyisodata(2656): Creating signature file: C:/Temp/imagine/name  
06/02/19 11:37:39 SessionMgr(14936): etif_HandleBlockRead failed  

06/02/19 11:37:40 SessionMgr(14936): etif_HandleBlockRead failed  

IM-46109 classifyisodata.exe 

crashes for running 
Unsupervised 
classification operator to 

an ECW output 

In ERDAS IMAGINE, open Spatial Model Editor.  

Drag and Drop Unsupervised classification operator.  
Double click the operator and specify 'Input Raster Layer' and 'Output cluster layer'.  
Input raster can be any format e.g. img.  

Output format should be ECW.  
Click ok and run the model.  
Observe run fails and session log info is as below:  

external process exited with status -1073741819.  
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IM-47278 Geophysical Processing 
not working in ERDAS 
IMAGINE 2018 

1.Launch ERDAS IMAGINE 2018.  
2.Launch Geophysical Processing from Raster > Classification > Unsupervised  
3.Provide the input as lanier.img , provide the output and click ok  

4.Observe Process failing and session log showing errors  
 
Session log: 

 
18/01/19 18:25:40 SessionMgr(11576): Connection success for the external process 
'eWkspace'  

18/01/19 18:26:08 eWkspace(6800): Loading [geophysical.eml]...  
18/01/19 18:26:37 C:/Program Files/Hexagon/ERDAS IMAGINE 
2018/bin/x64URelease/smprocess.exe 

$IMAGINE_HOME/etc/models/HorizonDip_NoClip.gmdx Raster 
Input.Filename=d:/2019/data_delete/lanier.img Raster Output.FilenameIn=d:/2019/16-01-
2019/delete/geop.img  

Raster Output.PixelType=F64 Band Selection.BandRange=1:1  
18/01/19 18:26:37 eWkspace(6800): Unloading [geophysicalalgorithms.eml]...  
18/01/19 18:26:38 SessionMgr(11576): Running spatial model 

($IMAGINE_HOME/etc/models/HorizonDip_NoClip.gmdx) with port values (Raster 
Input.Filename=d:/2019/data_delete/lanier.img,Raster Output.FilenameIn=d:/2019/16-01-
2019/delete/geop.img,Raster Output  

.PixelType=F64,Band Selection.BandRange=1:1).  
18/01/19 18:26:38  
18/01/19 18:26:38 smprocess:  

18/01/19 18:26:39 SessionMgr(11576): HexGeo::SpatialModeler::Operator::Execute failed  
18/01/19 18:26:39 HexGeo::SpatialModeler::Operator::Execute failed  
18/01/19 18:26:39 HexGeo::SpatialModeler::Operator::Execute failed  

18/01/19 18:26:39 HexGeo::SpatialModeler::Operator::Execute failed  
18/01/19 18:26:39 HexGeo::SpatialModeler::Operator::Execute failed  
18/01/19 18:26:39 HexGeo::SpatialModeler::Operator::Execute failed  

18/01/19 18:26:39 HexGeo::SpatialModeler::Operator::SetErrorMessage failed  
18/01/19 18:26:39 Spatial Model failed in Raster Input. The error was "No valid input 
Filename available".  

18/01/19 18:26:39 SessionMgr(11576): Spatial model failed.  
18/01/19 18:26:39  
18/01/19 18:26:39 SessionMgr(11576): smprocess.exe exited with status 1. 

IM-47261 Loading JP2 output from 
Unsupervised 

classification crashes 
ERDAS IMAGINE 

1.Launch ERDAS IMAGINE  
2.Launch Unsupervised classification from Raster > Classification > Unsupervised  

3.Provide the input as lanier.img  
4.Provide the output as unsuper.jp2 (File of type:JPEG2000)  
5.Provide the number of classes as 3 and click OK  

6.Process fails,, ignore it and try to load output from File open > Recent button  
7.Obvserve ERDAS IMAGINE crashes.   

IM-47533 LaGrange resampling 
method not present in 

Geophysical Processing 
dialog 

1.Launch ERDAS IMAGINE 
2.Select Geophysical Processing from Raster > Classification > Unsupervised > 

Geophysical  
3.Observe LaGrange resampling method not present but help page contain LaGrange also 

IM-46046 Opening this 
Hyperspectral Image is 
slow through Image 

Chain 

Open a specific .hdr hyperspectral image through Image Chain. Takes way too long. 
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IMAGINE SAR Interferometry 

Issue ID Summary – IMAGINE SAR 

Interferometry 

Description / How to Reproduce 

IM-45591 Coherence image produced 

by sentinel Swath CCD 
(mosaic) crashes 2D View 

Coherence image produced by sentinel Swath CCD (mosaic) crashes viewer. Simply 

open the image after mosaic. 

 

 

Spatial Modeler  

Issue ID Summary – Spatial 
Modeler 

Description / How to Reproduce 

IM-49746 Preview operator: Is not 
automatically re-
projecting feature data 

when a Basemap is 
displayed 

This problem occurs in ERDAS IMAGINE as well as in the Spatial Model Editor. A 
feature layer can be added to a 2D View window. When this occurs, the window 
recognizes and displays the data using the appropriate coordinate system. If a Basemap 

is displayed in the window, the feature data is automatically re-projected to register to 
the Basemap - in this case OpenStreetMap, which uses EPSG 3857. Following a similar 
workflow using the Preview command to display the feature data, the data is not 

automatically re-projected (correctly) when a Basemap is displayed in the Preview 
window. 
 

IM-46647 OLH-Description of one 

port missing in help for 
Machine Intellect 
Information operator 

1.Launch ERDAS IMAGINE 2018, and then launch Spatial Model Editor  

2.Drag the Machine Intellect Information operator to Spatial Model Editor.  
3.Observe MethodInformation port exists.  
4.Launch help page and observe no description MethodInformation port and the 

screenshot also needs to be updated. 

IM-46629 OLH-Description of one 

port missing in help for 
Image Segmentation FLS 
operator 

1.Launch ERDAS IMAGINE 2018, and then launch Spatial Model Editor  

2.Drag the Image Segmentation FLS operator to Spatial Model Editor.  
3.Check ON the Show All Ports option and observe Max Tile Size port exists.  
4.Launch Help page and observe no description for Max Tile Size port 

IM-46028 Proximity (and Cost) 

Spread operator's Help 
references a deprecated 
capability 

Start Spatial Model Editor  

Drag the Proximity Spread (or Cost Spread) operator onto the canvas  
Display the AutoStudyArea port  
Right-click on the Operator and select Help  

 
In the Help, look at the section for the AutoStudyArea port. It states:  
"If set to True, the StudyArea will be set to the same extent as the extent of 

OriginPointsRasterIn file. If set to False, the StudyArea is determined by the settings of 
Processing Properties dialog for the particular Spatial Model. Default setting is True."  
 

But there is no longer have a "Processing Properties dialog"  
Seems like the port has no purpose any more. 

IM-46624 OLH-Description of two 
ports missing in help for 
Raster Attribute Output 

operator 

1.Launch ERDAS IMAGINE 2018, and then launch Spatial Model Editor 
2.Drag the Raster Attribute Output operator to Spatial Model Editor.  
3.Check ON the Show All Ports option and observe Low Fill , High Fill exist.  

4.Launch Help page and observe no description for Low Fill , High Fill ports and also 
show all ports figure missing. 

IM-46623 OLH- No help for Sort 
Method in ICA operator. 

1.Launch ERDAS IMAGINE 2018, and then launch Spatial Model Editor  
2.Drag the ICA operator to S Spatial Model M Editor.  

3.Click on SortMethod port and launch help from SortMethod dialog pop-up  
4.Observe Help page navigating to errors page 

IM-46735 OLH for Machine Intellect 
Information operator 
needs to be updated 

A new output port, MethodInformation, was added to the operator in v16.5.2. But the 
OLH does not describe that port. 
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IM-46543 OLH-Create Centroid 
operator figure to be 
updated in help page. 

1.Launch ERDAS IMAGINE 2018 Update 2  
2.Launch Spatial Model Editor and drag Create Centroid operator to Spatial Model editor  
3.Launch online help and observe figure in help page and figure in UI are not same. 

IM-46564 OLH- Multi Filename 

input operator should be 
updated with Default and 
show all ports figures. 

1.Launch ERDAS IMAGINE 2018 Update 2 

2.Launch Spatial Model Editor, drag Multi Filename input operator to Spatial Model 
editor and launch help  
3.Observe operator in UI having only three ports but help shows four ports. Shown in UI 

by checking ON Show all ports 

IM-45008 Some operators to be 

updated with show all 
ports in the Help 

1.Launch IMAGINE 2016, Spatial modeler, check on show all ports.  

2.Drag these operators from the Surface category:  
* Aspect  
* Degreeslope 

* Insolatio  
* LeastCostPath  
* Percent Slope 

* Relief 
3.Click on each operator help and observe that help needs to be updated with figures 
corresponding to show all ports.  

IM-46027 Proximity Spread 

operator's Elevation 
Restriction dialog has no 
Help 

Start Spatial Model Editor  

Drag the Proximity Spread (or Cost Spread) onto the canvas  
Display the Elevation Restriction port  
Double-click the Elevation Restriction port to bring up the Elevation Restriction dialog.  

Click Help  
Help goes to the generic Help Error page 

IM-47761 Screenshot in the 
Generate Functional 
Attributes operator OLH 

should be updated 

The screenshot of the Generate Functional Attributes operator in its OLH mentions it as 
Functional Attributes. So the screenshot should be updated. Please see the attached 
screenshot. 

IM-46597 OLH- Create Buffer Ring 

operator help showing 
Inner Distance default 
value as Nearest 

Neighbor. 

1.Launch ERDAS IMAGINE 2018 Update 2  

2.Launch Spatial Model Editor from File > New  
3.Drag Create Buffer Ring operator to Spatial Model Editor and launch help  
4.Observe Inner Distance port showing default value as Nearest Neighbor, which was 

incorrect. 

IM-46596 OLH-Create Buffer Ring 
figures are placed instead 
of Create Buffer Zone in 

help page. 

1.Launch ERDAS IMAGINE 2018 Update 2, Launch Spatial Model Editor.  
2.Drag Create Buffer Zone operator and launch Help.  
3.Oberve Create Buffer ring operator figures are placed instead of Create Buffer Zone 

IM-46213 Join Features operator 

when Previewed for 2 
features with different 
Projection types, Preview 

is not correct even after 
Fit to Frame 

ERDAS IMAGINE 2018 Update 2 

1) Launch ERDAS IMAGINE > Toolbox Tab > Spatial Model Editor  
2) Open specific Spatial Model and then Preview  
3) Observe that the preview is blank initially, now Do Fit to Frame for the 2D Viewer  

Observe that the Features are not visible properly until its zoomed in  
   
Note:  

1) Here the FeaturesInLeft is having an input with State Plane projection and FeaturesIn 
Right is having UTM projection 
2) Even the other way around i.e., FeaturesInLeft with UTM projection and FeaturesIn 

Right with State Plane also has the same problem  
3) If both the Features of same projection, it shows the features properly after Fit to 
Frame 
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IM-46714 Summarize Related 
Features to Preview or 
Feature Output fails for 

specific geometry-based 
expression 

ERDAS IMAGINE 2018 Update 2 
Spatial Model contains two Features Input , Summarize Related Features, Preview and 
Features Output operators:  

-> on preview, displays blank Preview.  
-> running the model, errors out at Features output and creates a 1kb shp and shx file; 
0kb dbf file.  

 
(02/11/18 15:20:32 SessionMgr(8900): Executing spatial model  
02/11/18 15:20:32 SessionMgr(8900): erdas::sb_CGP::FeaturesOutput::OnExecute 

failed  
02/11/18 15:20:32 Unable to cast object of type 'Intergraph.Geometry.GDOBlob' to type 
'System.Byte[]'.  

02/11/18 15:20:32 SessionMgr(8900): Spatial model execution failed.)  

IM-46560 Default Values are not set 
in the ports of Create 
Buffer Ring and Create 

Buffer Zone operator 

ERDAS IMAGINE 2018 Update 2  
Default values of the Distance Units, Linear End Caps and Geometry Field Name are 
not set in the Operator UI as per the documentation of Create Buffer Ring and Create 

Buffer Zones operators 
 
Also if the Geometry Filed name is set it doesn't seem to add the field name in the 

output 

IM-47759 Expression allowed in the 

Generate Functional 
Attributes operator errors 
out when executed 

ERDAS IMAGINE 2018 Update 2 

 
Open a specific Spatial Model containing a Generate Functional Attributes operator and 
click Preview 

 
20/02/19 11:16:45 SessionMgr(57492): ERROR: #125 from featuresvlLayerCreate  
20/02/19 11:16:45 SessionMgr(57492): ERROR: Error happened during compilation of 

the expression with message: System.CodeDom.Compiler.CompilerErrorCollection.   

IM-48952 The datatype in the user 

interface (UI) for a port of 
some operators isn't in 
sync with OLH. 

The datatype for a port of the following operators in the UI is 

HexagonGeospatial.FeaturesAnalysis.FunctionalAttribute. Whereas in the OLH it is 
IMAGINE.FunctionalAttribute.  
 

* SummaryAttribute1 port of Summarize Related Features operator  
* Functional Attribute1 port of Generate Functional Attributes operator  
* Functional Attribute port of Define Functional Attribute operator  

* SummaryAttribute1 port of Merge Features operator  
 
UI and OLH for these operators should be in sync. 

IM-48349 Running “Raster Statistics 

per Feature” operator is 
hanging and eventually 
crashing ERDAS 

IMAGINE 

Customer reported that they tried to run the “Raster Statistics per Feature” operator to 

get the mean value of a polygon. When they run the process, ERDAS IMAGINE is 
hanging and eventually crashing. 
 

IM-48363 Input calibrated files are 

incorrectly placed in 
output PDF by Create 
Geospatial PDF operator 

Run specific Spatial Model.   

Open the output pdf file.  
Observe output of ERDAS IMAGINE 2018 Update 2 are incorrectly placed.  
Valid output is created in ERDAS IMAGINE 2016 only. 

IM-41134 Progress bar stays at 0% 

when running Machine 
Learning operators 

All Python-based Machine Learning operators have this problem. 
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IM-46592 Executing Machine 
Learning (ML) Process -
session log pointing to 

unknown classification 
server 

1.Launch ERDAS IMAGINE 2018 Update 2 and change to Machine Learning Layout.  
2.Select ML Train and train a model by collecting image chips for a few classes.  
3.Now select ML Process tab, create a Project and try to execute the ML Process by 

selecting the model created in step2.  
4.Observe that session log showing classification server pointing to 
C:/tf_jenkins/workspace/rel-win/M/….etc. This does not exist in the system.  

 
NOTE: In this work flow execution was success and classification done.  
 

Session log: 
  
22/10/18 15:15:51 C:/Program Files/Hexagon/ERDAS IMAGINE 

2018/bin/x64URelease/MachineLearningProcessChain.exe d:/2018/19-10-
2018/lauoutproject2.mlp 1 Run 1  
22/10/18 15:15:57 SessionMgr(3436): Starting classification server process...  

22/10/18 15:16:27 SessionMgr(3436): Classifying 
C:/Users/agangumo/AppData/Local/Temp/SPATIAL_MODELER-5ec4-774c-9a62-155a-
009920/cc4ac0f0-17a9-492c-ba2c-92a297e68855img  

22/10/18 15:16:27 SessionMgr(3436): classification server: 2018-10-22 
15:16:27.207485: I C:\tf_jenkins\workspace\rel-win\M\windows-
gpu\PY\35\tensorflow\core\platform\cpu_feature_guard.cc:140] Your CPU supports 

instructions that this TensorFlow binary was not compiled to use: AVX2 
22/10/18 15:16:27 SessionMgr(3436): classification server: 2018-10-22 
15:16:27.539761: I C:\tf_jenkins\workspace\rel-win\M\windows-

gpu\PY\35\tensorflow\core\common_runtime\gpu\gpu_device.cc:1212] Found device 0 
with properties:  
22/10/18 15:16:27 SessionMgr(3436): classification server: name: Quadro M1200 major: 

5 minor: 0 memoryClockRate(GHz): 1.148  
22/10/18 15:16:27 SessionMgr(3436): classification server: pciBusID: 0000:01:00.0  
22/10/18 15:16:27 SessionMgr(3436): classification server: totalMemory: 4.00GiB 

freeMemory: 3.35GiB 

IM-47764 Doc: Classify using 

machine learning has a 
limitation on raster data 
type that needs to be 

documented 

Raster Classification using Machine Learning fails if the data has No Data set or if the 

data type is Double. Here is the error message from the session log.  
 
12:16:13 SessionMgr(9000): Input contains NaN, infinity or a value too large for 

dtype('float32'). 

IM-47505 Initialize Inception 
operator performs 
validation test even when 

no data is set aside for 
validation 

It seems Initialize Inception always performs validation even when no data is set aside 
for validation.  With Validation percentage set to zero, I still get some percentage values.  
 

In the session log, I see this   
Step 99: Validation accuracy = 84.0(N=100)  
 

This should not be the case if I have not reserved any data for validation. 

IM-43613 Criteria Selection on the 

Probability field in 
Machine Learning Layout 
crashes ERDAS 

IMAGINE 

On the File tab, change to the Machine Learning Layout  

Load a project that you've already trained and classified.  
Load the results.  
In the Change Likelihood Rank panel right click in the Row column and select Criteria...  

Use the Selection Criteria dialog to specify  $"Probability" > .5  
Click Select.  
ERDAS IMAGINE crashes 

IM-42556 Session log records a 

warning message when 
running a model 
consisting of Machine 

Learning operators 

Steps To Reproduce: 

(1) Create a valid model with any of the Machine Learning operators.  
(2) Run the model  
 

Observation: 
Session log records a warning message as below:  
{color:#d04437}11/12/17 13:54:21 eWkspace_64(17412): 

WARN  com.hexgeo.smsdk.spatialmodeler.core.Data - SizeInBytes must be 
implemented for data type: IMAGINE.FeatureSubset{color} 
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IM-42504 Zonal Max operator does 
not support float data 

Zonal Max operator only outputs integer data. This causes a problem if the input is data 
type is float - the output values lose precision. It really causes a problem if the input data 
type is float and the values are negative - the Zonal Max always outputs a value of 0 

instead of the true negative zonal max value. 
  
Whereas the Zonal Attributes tool (Save Zonal Statistics To Polygon Attributes) outputs 

correct zonal max floating point values.  

IM-42614 Select Attributes is 
throwing an error dialog 
on removing all the 

attributes from the 
included list 

Steps to reproduce: 
(1) Create a spatial model as follows: 
Feature Input > Select Attributes > Initialize Naive Bayes > ... 

(2) In 'Feature Input' select any shapefile that has some attributes defined.  
(3) On 'Select Attributes' operator double-click on the 'AttributeNames' port to bring up 
Select Attributes dialog. 

(4) From the 'Available Attributes' list add couple of attributes to the 'Included Attributes' 
list.  
(5) Once the attributes are listed in the 'Included Attributes' list, remove both the listed 

attributed by clicking "<" tool bar icon. 
Observation: 
(6) An error dialog is thrown when the last attribute from the list is removed 

 
Session log records:  
_{color:#d04437}13/12/17 12:43:42 SessionMgr(4132): ERROR: #223 from 

ScrollList::SelectByPos(){color}_  
_{color:#d04437}13/12/17 12:43:42 SessionMgr(4132): ERROR: 
eeml_ScrollListSelectByPos failed{color}_  

_{color:#d04437}13/12/17 12:43:42 SessionMgr(4132): ERROR: #2 from 
eeml_ScrollListSelectByPos{color}_  
_{color:#d04437}13/12/17 12:43:42 SessionMgr(4132): ERROR: Scrollist has no 
members in the set!{color}_ 

IM-48617 Convert to Surface 

operator fails if it is used 
in combination with other 
point cloud operators 

Convert to Surface fails if it is used in combination with other point cloud operators. 

 
But if the intermediate result is saved to a file and the file is then used as an input to 
convert to surface operator, it works fine. 

IM-48885 Stack Max operator does 
not output correct value if 

the input is a negative 
floating point number 

Stack Max operator always returns a value of 2.22507e-308 if the input value is negative 
and the data is 64-bit floating point. It returns a value of 1.17549e-038 if the input is 32-

bit floating point data.  
 
These are not the correct values. 2.22507e-308 is the maximum value for the floating 

point 64-bit data and 1.17549e-038 is the maximum value for the floating point 32-bit 
data. 
 

Stack Max operator provides the correct output value if the input is a negative 8-bit or 
16-bit value. This problem does not occur with ERDAS IMAGINE 2016 Update 1. 

IM-46535 Measure Area is affecting 
the geometries (some 

large holes are being 
filled) 

ERDAS IMAGINE 2018 Update 2  
 

A Spatial Model was built which takes an input shapefile, merges features and then 
measures the Area of each feature.  
The result of the merge appears to be correct, but the result of the subsequent Measure 

Area are wrong - large holes in the original geometries have been filled (i.e. removed). 
  
Measure Area should not affect the geometries at all!  

 
Measure Perimeter has the same effect on the geometries.  
 

Also tried Measure Length and Measure Center and they all modified the output 
geometries. 
 

As a workaround, use Generate Functional Attributes again.  
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IM-49761 Spatial Model changes 
datum of input feature 
data 

When processing input feature data that are projected to Lambert Conformal Conic with 
the datum “MGI AT (EPSG: 1618)”, the output features and raster data have a different 
datum, which causes a shift of approximately 300 meters in the X-direction. The output 

features data are assigned the datum “MGI”. The output raster data is assigned the 
datum “Militar-Geographische Insttut [To WGS 84 8]”. 

IM-44602 Producing ER Mapper 
(*.ers) file from vector file 

throwing error in ERDAS 
IMAGINE 2018 

1.Launch ERDAS IMAGINE 2018  
2.Launch Spatial Model Editor, create model Features Input > Convert to Raster > 

Raster Output  
3.Provide the input as *cities.shp* and output raster as *ermapp.ers*  
4.Run the model and observe an error thrown Vector<T> too long 

IM-46625 One extra port 
(Expression) shown for 

the operator Point Cloud 
Build Selection Criteria 
operator in UI 

1.Launch ERDAS IMAGINE 2018 Update 2, launch Spatial Model Editor  
2.Drag Point Cloud > Build Selection Criteria operator to Spatial Model Editor.  

3.Check ON show all ports, observe Expression port present. This is not explained in 
Help. 

IM-46381 OLH Default values 

disagree with Filter By 
Geometries operator 

1.Launch ERDAS IMAGINE 2018 Update 2 

2.Launch Spatial Model Editor from File > New  
3.Drag Filter By Geometries operator to Spatial Model Editor  
4.Click SpatialOperator port and observe default value is set to Meet but OLH says 

default value is Touch  

IM-39578 Convolve a F32 DEM 

using non-normalised 
Kernel, fails with Unable 
to allocate OpenCL 

Image message 

Open specific spatial model in the Editor.  

Click Run  
 
See these messages in the Message panel and the model fails to run:  

Unable to allocate OpenCL Image  
Unable to allocate OpenCL Image  
Unable to allocate OpenCL Image  

Unable to allocate OpenCL Image  
Unable to allocate OpenCL Image  
Unable to allocate OpenCL Image  

Unable to allocate OpenCL Image  
Unable to allocate OpenCL Image  
 

If you change the Input Raster from Native Type to Float (which should be the same) the 
model runs successfully.  
 

Or, you can leave it as Native Type, but change Normalize to True on the input kernel. 
That works as well.  
 

Note – if you close ERDAS IMAGINE after attempting (and failing) to run this model, you 
get a Runtime Error. 

IM-45023 Initial input values in 
Spatial Model Editor 
causes errors 

Spatial Modeler reports an error on initial inputs.  
Test Model is in: \\alpha\JIRA_data\IM-45023  
 

Open Spatial Modeler  
Scenario 1:   
# Load model from above folder  

# Run model  
# When the dialog opens, press "OK" without changing any values.  
# Output should report an error.  
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IM-45259 Slope to NTF give errors 
in the session log 

Run a specific Spatial Model which generates slope from a DEM and outputs to NITF 
format.  Notice the errors in the session log:  
 

09/07/18 11:14:43 SessionMgr(18828): ERROR: #22935 from 
eimg::details::SSLayerGetNames  
09/07/18 11:14:43 SessionMgr(18828): ERROR: <NULL> failed  

09/07/18 11:14:43 SessionMgr(18828): ERROR: #67 from <NULL>  
09/07/18 11:14:43 SessionMgr(18828): ERROR: eimg_FileImageNamesGet failed  
09/07/18 11:14:43 SessionMgr(18828): ERROR: #14930 from 

eimg_FileImageNamesGet  
09/07/18 11:14:43 SessionMgr(18828): ERROR: eimg_FileOpen failed  
09/07/18 11:14:43 SessionMgr(18828): ERROR: #5968 from eimg_FileOpen  

09/07/18 11:14:43 SessionMgr(18828): ERROR: c:/work/output.ntf.r2: eimg_FileOpen 
failed (33:Unsupported Raster format or non-Raster format) 
 

It looks like when outputting NITF in this case, we try to compute stats while generating 
RSETs, which tries to open the RSET as it's being generated (and fails).  It doesn't 
seem to negatively affect the process though.  

IM-46858 Rename Attributes does 

not work 

Open a specific Spatial Model desinged to take an input shapefile, attempts to rename 

one of the attribute fields and write out a new shapefile.  
However if you click Preview (or Run) you'll get this error:  
 

Spatial Model failed in Rename Attributes. The error was  
"HexGeo::SpatialModelerFeatures::Feature::TransferFieldValue  
failed Unsupported field type". 

IM-46567 OLH Default values 
disagree with Compute 

Affine Coefficients 
operator 

1.Launch ERDAS IMAGINE 2018 Update 2  
2.Launch Spatial Model Editor from File > New  

3.Drag Compute Affine Coefficients operator to Spatial Model Editor  
4.Observe default value set for Scale X ,Scale Y ports are 0 but OLH says default 
values are 1  

IM-46565 OLH Default values 
disagree with APM 

Parameters operator 

1.Launch ERDAS IMAGINE 2018 Update 2 
2.Launch Spatial Model Editor from File > New  

3.Drag APM Parameters operator to Spatial Model Editor  
4.Observe default value set for PointsPerImage port is 25 but OLH says default value is 
9  

IM-46762 Some LAS inputs cause 

the Classify Ground 
Operator to crash ERDAS 
IMAGINE 

Classify Ground operator causes ERDAS IMAGINE to crash with some point cloud input 

files. The cause of the problem has been identified with using point cloud files small 
enough not to need tiling.  
 

After a crash you may see a session log error that looks like:  
14/11/18 09:22:16 SessionMgr(4972): Executing spatial model: 
//cheryltest/sfdc/00036404_cloud_crash/classifyground/groundpoints.gmdx  

14/11/18 09:25:45 SessionMgr(4972): external process exited with status -1073741819.   

IM-46705 Spatial Model failed in 
Add Attribute By Order 

Customer submitted a model where errors are reported at the Add Attribute By Order 
operator. Tests indicate the source of the errors may be coming from how the Filter By 
Geometries Operator is sending the temporary output to the next operator. 

 
31/10/18 13:47:05 SessionMgr(3336): ERROR: #2348 from 
HexGeo::SpatialModeler::Operator::InternalApply  

31/10/18 13:47:05 SessionMgr(3336): ERROR: 
HexGeo::SpatialModeler::Operator::SetErrorMessage failed  
31/10/18 13:47:05 SessionMgr(3336): ERROR: #1985 from 

HexGeo::SpatialModeler::Operator::SetErrorMessage  
31/10/18 13:47:05 SessionMgr(3336): ERROR: Spatial Model failed in Add Attribute By 
Order.  The error was "Table count 209 does not match FeaturesIn count 14.".  

31/10/18 13:47:06 SessionMgr(3336): Table count 209 does not match FeaturesIn count 
46. 
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IM-48093 Add Attributes by 
Location does not accept 
just DN values 

Add Attributes by Location seems to rely on there being an attribute table present on the 
raster stream. Whereas, frequently there will not be if the raster stream has been 
generated as part of the model.  

 
Open specific Spatial Model in a Spatial Model Editor  
Click Run.  

Note that the second Add Attributes by Location fails with a message "can't find attribute 
table"  
The only difference between the two Add Attributes by Location operators is that in the 

second one, the input raster stream has been multiplied by 2, thereby invalidating its 
attribute tables (but still having DN values).  
If instead you attach the output of Attach Attributes to the Related Data port of Add 

Attributes by Location 2, it runs successfully.  
 
Help states that DN values should be supported. It needs to be.  

IM-48392 Add Attributes By 

Location operator fails 
with float values 

Add Attributes By Location operator fails when the input raster is of float data type.  

 
9/04/19 17:46:18 SessionMgr(23780): ERROR: #1985 from 
HexGeo::SpatialModeler::Operator::SetErrorMessage  

09/04/19 17:46:18 SessionMgr(23780): ERROR: Spatial Model failed in Add Attributes 
By Location. The error was "HexGeo::SpatialModeler::Typedefs<class 
HexGeo::SpatialModeler::Data>::CastRef failed  

09/04/19 17:46:18 Unable to cast a class HexGeo::SpatialModeler::Data to a struct 
HexGeo::SpatialModeler::DoubleData".  

IM-18871 ERDAS IMAGINE 
crashes while saving 
read-only Spatial Model 

Open a read-only Spatial Model file 
Add a new operator to the Spatial Model 
Click on the Close button of Spatial Model Editor 

Click Yes button of 'Verify Save on Close' Dialog 
Observe that ERDAS IMAGINE crashes 

IM-46622 ERDAS IMAGINE 
crashes with ICA operator 

if Count exceeds number 
of bands 

1.Launch ERDAS IMAGINE 2018, launch Spatial Model Editor  
2.Connect a Model as Raster Input > ICA  

3.Provide inputs  
* Raster Input : sub4road1.img (a 3 band image) from examples > Objective  
* Count : 16  

* Sort Method: ICASORT_SKEWNESS  
4.Click Run to execute model , observe ERDAS IMAGINE crashes.  

IM-46536 ERDAS IMAGINE 
crashes while creating 
Geometry using Create 

Bounding Box operator 

1.Launch ERDAS IMAGINE 2018 Update 2  
2.Launch Spatial Model Editor and open specific Spatial  
3.Click on preview and observe ERDAS IMAGINE crashes. 

IM-34996 Convert to Features 
output does not carry the 
attributes of the input if 

"IsClumped" option is 
OFF 

ERDAS IMAGINE 2016 Update 1 
- Give Lnsoils.img from the example data as an input to *Convert to Features* operator 
and generate an output using the default options.  

- Open the output shapefile in the viewer and check the Attribute table. 
Notice that the attributes from the input thematic image are missing. 
 

Repeat the same with the "IsClumped" option ON and notice that the attributes are 
carried to the output. 

IM-49241 Add Attributes By 
Location takes wrong 
values if no related data 

found 

If the operator Add Attributes By Location cannot find a suitable object to fill attributes, 
the attributes of the object with previous Primary Key value are taken to fill the attribute 
table. This is wrong. The entry should stay empty instead. 

IM-49459 Update Statistics operator 
not properly setting skip 

factors, exclude values, 
etc. 

Update Statistics operator is not writing the correct Statistics Parameters and Histogram 
Parameters (skip factors, exclude values, bin function, and AOI) to the image layers. 

It's writing out the default values, not what was actually used for the stats.  
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IM-49456 Add Attributes by 
Location operator causes 
ERDAS IMAGINE to exit 

ERDAS IMAGINE 2018 Update 2  
 
See specific Spatial Model 

Open the model in Spatial Model Editor  
Double-click the <StringList> port on the Add Attributes by Location operator. This 
should open a dialog enabling you to select attribute names  

ERDAS IMAGINE exits. 

IM-48930 Least Cost Path model 
hangs 

See the data and model available here: 
 
https://community.hexagongeospatial.com/t5/Spatial-Modeler-Tutorials/Calculating-a-

Least-Cost-Path-using-a-DEM/ta-p/6115 
 
In ERDAS IMAGINE 2016 v16.1 you can open this model in the Spatial Model Editor 

and run it to completion in about 4 minutes.  
If you try to do the same in ERDAS IMAGINE 2018 it just hangs in the Least Cost Path 
operator. 

IM-46540 Density Interpolation 
operator throwing error in 

combination with Create 
Center Point operator 

The problem is with the way the Density Interpolation operator interprets the primary 
geometry field of the input features. Output features from the Create Centerpoint 

operator contain 2 geometry fields, the original input areas and the newly created 
centerpoints. The operator also correctly sets the primary geometry to GC_Centerpoint, 
which can be proven by passing features into the Features Information operator and 

observing the PrimaryGeometryFieldName port.  
 
When passing features directly from Create Centerpoint to Density Interpolation, the 

Density Interpolation operator incorrectly attempts to use the original area geometry field 
"Geometry" presumably because it appears first in the list.  

IM-44641 Rapid Atmospheric 
Correction tool does not 
pass calibration file to 

Spatial Model 

The calibration file is not getting passed from the Rapid Atmospheric Correction tool to 
the Rapid Atmospheric operator in the Spatial Model. When you try to run the tool, the 
process fails. Session log reports the error "No input file available".  

 
To work around this problem, click the View button in the Rapid Atmospheric Correction 
tool and it opens the spatial model. Double-click on the CalibrationFilename input port 

for the Rapid Atmospheric operator and select the calibration file, then run the spatial 
model. 

IM-47466 Performing a sort on a 
Features Table column in 

Connection Manager 
dialog crashes Spatial 
Model Editor 

A crash of the Spatial Model Editor application occurs when the Connections Manager 
dialog is used to make a proxy file connection (for Oracle, PostGIS, or SQL Server) if 

the Feature Tables list is then sorted (by selecting the ‘Name’ column and choosing the 
‘Sort A..Z’ or ‘Sort Z..A’ option). 

IM-46722 Previewing a raster with 0 

rows and 0 columns 
crashes ERDAS 
IMAGINE 

After analyzing why a customer's Spatial Model was crashing, in the end tracked it down 

to an error defining the output pixel dimensions that resulted in an output raster with no 
rows or columns. Previewing this crashes ERDAS IMAGINE. 

IM-35174 Raster (Color) Attribute 

Output wipes Color Table 
with u8 output 

See model attached.  

 
You can use Bands 4 and 3 from a Landsat dataset such as this one:  
\\alpha\ARRAY5\Cherokee County Data\Landsat\New Landsat Data\Landsat 5 May1997  

 
Open the model in Spatial Model Editor.  
Click Run.  

Leave Stretch flag set to False (so you'll get floating point NDVI results), fill in the input 
images, click OK.  
Open the resulting image file as PseudoColor.  

Results look good (dark to light green color ramp is applied – let’s ignore the fact that it 
seems to have created a valid color for NoData).  
Click Run again and give a different output file name.  

Change Stretch flag to True (to give u8 output).  
Open the resulting image file as PseudoColor.  
The image is displayed all black because the colors applied to each class are all black. 

https://community.hexagongeospatial.com/t5/Spatial-Modeler-Tutorials/Calculating-a-Least-Cost-Path-using-a-DEM/ta-p/6115
https://community.hexagongeospatial.com/t5/Spatial-Modeler-Tutorials/Calculating-a-Least-Cost-Path-using-a-DEM/ta-p/6115
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IM-35173 Attach (Color) Attributes 
does not work with 
Floating Point output 

Open a specific Spatial Model in Spatial Model Editor.  
Click Preview.  
Leave Stretch flag set to False (so you'll get floating point NDVI results), fill in the input 

images, click OK.  
Results look good (dark to light green color ramp is applied).  
Click Run.  

Open the resulting image file as PseudoColor.  
No color ramp was saved to the output file (so it does not look the same as the Preview) 

IM-47841 RGBtoIHS causes stats 
problem when data is out 

of specified range 

A Spatial Model was build which performs a RGB to IHS on an input 8-bit RGB image. 
However, the actual data range of the input image exceeds the specified Max values on 

the RGB to IHS operator, causing problems in a subsequent Statistics operator. 

IM-47534 Preview of DirectLookup 

not behaving well when 
Table is a color table 

* Build a Model like this with a Thematic input image: 

  
* Click Preview  

* On the Multispectral tab, try changing the band combination. Notice that nothing 
happens.  
* Select the Panchromatic Image Chain. You'll get red Xs.  

IM-46904 NDVI model from the 
Ribbon GUI ignores the 

‘stretch to Unsigned 8 bit’ 
option 

Running NDVI from the ribbon gui does not produce a properly rescaled image when 
using ‘Stretch to Unsigned 8 bit’. The output value range is 0 – 1.  

 
After selecting the *Stretch to Unsigned 8 bit* option from the I/O options tab, the default 
spatial model opened from the NDVI dialogue's View button has the StretchFlag value in 

the Properties dialogue set to Integer (0) and produces the same unexpected result. If 
you change the StretchFlag value to Integer (1), the model rescales the output image to 
a 8 bit value range that appears to be correct.  

IM-48405 Remove Item fails when 

DataIn is a Table 

Remove Item operator says that it supports "Dictionary, List (of Data), and Data" for 

DataIn. There's a TableToList conversion, so you'd think that you could remove items 
from a Table.  
 

But it fails, even though the connection is not shown in red. 

IM-48058 Example 2 missing from 

Spatial Modeler Guide 

Apparently this got lost. All the current Guide says is "Example 2: Load/Save/Edit a 

Spatial Model".   

IM-49513 Feeding an AOI to 

Features Input causes 
ERDAS IMAGINE to exit 

ERDAS IMAGINE 2018 Update 2  

 
Start Spatial Model Editor  
Add a Features Input operator  

Double-click the input port  
In the File Chooser select the All Files (*.*) filter option  
Select an .AOI file and OK the file Chooser  
Click Run  

ERDAS IMAGINE exits.  
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IM-49575 ERDAS IMAGINE 
crashes with model 
containing Update 

Attribute operator 

1.Launch ERDAS IMAGINE 
2.Launch Spatial Model Editor and Load the model and click on Preview. 

3.Observe ERDAS IMAGINE crashes.   

IM-47233 Set Primary Geometry 

operator UI does not 
present all available 
geometry fields with IFC 

format 

Attempted to use Set Primary Geometry to select a geometry field in a model but was 

unable to select the field via the dialog, entering it manually worked fine. The model 
uses Generate Functional Attributes to create a new geometry field. This new field 
becomes primary after GFA executes.  

 
Wanted to use Set Primary Geometry to set the original geometry field back to primary. 
However, it was not in the drop down list on the UI. 

IM-49844 Convert to Features 

operator fails in execution 

Click Preview  

Model fails in the Convert to Features operator  

IM-40485 Alert messages in Python 

while running Spatial 
Model containing the 
Generate Surface 

operator 

Customer reported that when running a python script that is using a Spatial Model 

containing the Generate Surface operator, they get alert messages about starting 
processing pyramid levels. The user had to manually click OK in order the Python script 
to process to the next pyramid levels. This continues until all the pyramids levels are 

processed.  

IM-46859 Previewing a Model 
containing Rename 
Attributes has scale-

dependent problems 

Open specific Spatial Model in the Spatial Model Editor.  
Click Preview  
The model successfully previews the buffer "donuts" in a View  

Now zoom in in the Preview.  
At some stage the geometries stop drawing.  
Zoom back out and they re-appear. 

IM-47572 Operators do not warn if 

an inappropriate object 
type is connected to them 

The following two operators do not warn (red color connection) if an inappropriate object 

type is connected to them.  
# Initialize Deep Intellect – AddLayer1 port is expecting a Dictionary object type. But it 
does not warn if any other object type is connected to it.  

# Detect Objects Using Deep Learning – MachineIntellect port expects a 
MachineIntellect object type. But it does not warn if any other object type is connected to 
it. 

 



 

4 October 2019  77 

IM-46526 Preview results from 
Convert to Surface 
operator are incorrect 

ERDAS IMAGINE 2018 Update 2  
A Spatial Model was built which takes vectors with a height attribute and runs them 
through Convert to Surface and sends to a Preview.  

 
Click Preview  
 

At first the results may appear correct. But if you zoom in to the area that has been 
interpolated, the results chop and change - sometimes large gaps appear, sometimes 
almost all the interpolated values disappear, etc.  

Also, when you open the Inquire Cursor, it reports NoData for the interpolated areas.  
However, when you click Run and output a file of the interpolation, the results look fine. 

IM-49617 Error opening image with 
Elevation Info in Image 

Metadata in Spatial 
Modeler SDK 

In an installation of Spatial Modeler SDK: 
# Launch Spatial Model Editor  

# Launch Image Metadata  
# Open lndem.img in the Image Metadata tool 
 

Error  
10/07/19 12:34:26 imageinfo(21724): Error opening file [recalculateelevation.eml] for 
input!  

10/07/19 12:34:28 SessionMgr(11492): ERROR: #8226 from eeml_Parse  
10/07/19 12:34:28 SessionMgr(11492): ERROR: Problem in EML macrofile 
recalculateelevation.eml  

10/07/19 12:34:28  
10/07/19 12:34:28 SessionMgr(11492): ERROR: #1156 from elex_Parse  
10/07/19 12:34:28 SessionMgr(11492): ERROR: Input is empty Error processing 

unknown file at or near "Unexpected End"  
10/07/19 12:34:28 SessionMgr(11492): ERROR: #1 from eeml_Parse  
10/07/19 12:34:28 SessionMgr(11492): ERROR: Input is empty  

IM-49558 Point Cloud > Convert To 
Surface output is too 

small 

Both 32- and 64-bit versions of the operator are generating output files that are much 
too small, only several pixels large. 

IM-43943 Spatial Model Editor 

"hangs" 

ERDAS IMAGINE 2018 Update 1: 

Open specific Spatial Model in Spatial Model Editor.  
Scroll over until you can see the Zonal Summary Max operator.  
Right click on it and select Run Just This.  

Once it has completed left-click on the Summary operator.  
 
The Spatial Model Editor may immediately go "busy". If not, try to pan the model using 

the middle mouse button. At some stage the Editor decides to go "busy" for a minute or 
so. Eventually you might get control back, but left-clicking on the Zonal Summary Max 
operator sets it off again and you have to wait, again.  

IM-34174 Spatial Model operator 
Bitwise Not is giving 

output Binary(1) even if 
the input is Binary(1) 

Customer reported that when using the Bitwise operator Not, if false is input, it returns a 
true, if true is input, it returns a true. 

 
Steps to reproduce: 
1. Create new spatial model, drag Bitwise Not in 

2. Use true as input, change to Binary(1) 
3. Run model, output is Binary(1) 
However, using false, the result is the same. 

IM-20602 Raster Input operator is 

failing while displaying 
VMCX file pointing to 
PNG in Spatial Model 

Editor 

Display a VMCX file pointing to PNG using a Spatial Model (Port Input > Raster Input > 

Preview). Randomly Raster Input Operator is failing (cross mark). 
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IMAGINE Terrain Editor 

Issue ID Summary – IMAGINE 

Terrain Editor 

Description / How to Reproduce 

IM-42325 Recalculate Elevation for 

Images no longer offers 
millimeters as an elevation 
unit 

Users need the ability to change elevation height units to millimeters. This cannot be 

done with the Recalculate Elevation for Images tool found under the Terrain tab 
(Manage group) or within the Image Metadata tool (or the Image Commands tool). 

IM-41348 Geomorphic Edits not 

saved 

In some cases when applying geomorphic edits, they are not being saved. This seems 

to happen randomly but more often when one closes the Terrain Editor dialog and 
clicking the save button from the popup dialog when prompted to save the changes.  

IM-31142 Move AOI Home icon is 
changed in Terrain Editor 

Launch ERDAS IMAGINE.  
Load a block file having DEM. 
Launch Terrain Editor.  

Go to Terrain Files and Display tab > Area of Interest section > Navigation > Center 
icon i.e 'Move AOI Home' icon is changed from house symbol to dot. 

IM-46872 Unknown characters 
shown on Button Mapping 

Window Title 

1.Launch ERDAS IMAGINE 2018  
2.Load any photogrammetric project  

3.Launch Terrain Editor window.  
4.Launch Button Mappings from Edit > Devices > System Mouse  
5.Observe that unknown characters shown on Button Mapping Window Title. 

IM-46903 Terrain Editor produces 
errors when editing 

geographic LTFX DTMs 

When points of a geographic LTFX DTM are edited with the Terrain Editor in a 
geographic projection blockfile, the changes are very often not saved. The effect could 

not be observed using UTM LTFX DTMs generated within a UTM blockfile. 

IM-47462 Terrain Prep Tool cannot 
merge two overlapping 
LAS files using both Thin 

and Filter preprocessing 
options 

If you try to create a DEM from two overlapping LAS files using either the Surface 
process (Rasterization) or the Merge process, it fails at the merge step if both the Thin 
and Filter preprocessing options are enabled. If you only use one of the preprocess 

settings (Thin or Filter) it works as it should.  

 

 

IMAGINE Expansion Pack – 3D 

Issue ID Summary – IMAGINE 

Expansion Pack 3D 

Description / How to Reproduce 

IM-48196 ERDAS IMAGINE crashes 
while selecting Digitize 
Flight Path with Tablet in 

3D view 

1.Launch ERDAS IMAGINE (64-bit)  
2.Close 2D view and create new 3D View  
3.Select Scene tab and launch Flight Path Editor from Navigation group  

4.Select New Configuration from Flight Path Editor > Utility > Digitize Flight Path With 
Tablet  
5.Observe ERDAS IMAGINE crashes.  

IM-45759 Unable to Start Movie 
Recording of type 

Microsoft AVI in 3D view, 
as file was defaulting to a 
.mpg extension 

1.Launch ERDAS IMAGINE 2018 Update 2  
2.Close 2D View and launch 3D View from Add views > Create New 3D View  

3.Load data  
4.Click on Start button from Scene tab > Recording  
5.Provide the output movie file as test.avi.  

6.Click OK and observe a dialog opens. Unable to start Movie recording. This is not the 
case with File of type IMAGINE Movie (*.mov)  
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IMAGINE Expansion Pack – AutoSync 

Issue ID Summary – IMAGINE 

Expansion Pack 
AutoSync 

Description / How to Reproduce 

IM-47057 AutoSync not displaying 
coordinates legibly 

Start AutoSync workstation and load a specific project.  
Points have already been generated.  
Try to read the coordinates - you cannot because the significant digits have been 

displaced off the left side of the columns. 

IM-47056 AutoSync not recognising 
RPC model as being valid 

See the Community thread here:  
 
http://community.hexagongeospatial.com/t5/Spatial-Modeler/autosync-automatically/m-

p/29178/highlight/false#M518 
  
Start AutoSync workstation and load a specific project.  

Points have already been generated so click the Sigma button to try to solve the RPC 
models the input images are calibrated with.  
Error  

Invalid output geometric model  

IM-45119 AutoSync workstation 

crashes while creating 
GCP with single input 
image 

1.Launch ERDAS IMAGINE and launch Autosync Workstation  

2.Create a Project as Georeference workflow  
3.Provide input image as residential.image from Examples > Objective  
4.Click on Create GCP button and Click on input image and observe AutoSync crashes.  

IM-46612 AutoSync CellArray 

displays values with 
incorrect formatting 

ERDAS IMAGINE2018: AutoSync CellArray format displays coordinate values in the 

cell array that are not right justified and contain an excessive number of decimal places.  
 
Autosync 2016 displays the cell array values as expected.  

 
Coordinate values are represented 8 decimal places. 
Residual values are represented with 16 decimal places.  

 
Compare with  Autosync 2016. The numerical values are right-centered with the 
coordinate values represented with 3 decimal places and the Residual values 

represented with 6 decimal places. 

IM-47855 Run APM does not do 

anything in AutoSync 2018 
with data in custom datum 
and projection 

Customer is using a custom datum and projection in Autosync for georeferencing ZY3 

sensor data. According to the customer in ERDAS IMAGINE 2018 with Update 1 or 2, 
Autosync is unable to start the “Run APM” . The session log gives the following error 
message: 

 
28/02/19 16:09:47 SessionMgr(13104): WARNING! The two images do not overlap with 
each other, output may not be generated.  

 
The problem does not occur if ERDAS IMAGINE 2018 without Updates is used. 

 

 

  

http://community.hexagongeospatial.com/t5/Spatial-Modeler/autosync-automatically/m-p/29178/highlight/false#M518
http://community.hexagongeospatial.com/t5/Spatial-Modeler/autosync-automatically/m-p/29178/highlight/false#M518
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IMAGINE Expansion Pack – NITF 

Issue ID Summary – IMAGINE 

Expansion Pack NITF 

Description / How to Reproduce 

IM-45772 SNIP NITF: 1.5 minutes to 

display image 

ERDAS IMAGINE 2018 Update 2 

Start ERDAS IMAGINE  
Click the File icon on the Quick Access Toolbar.  
Select a SNIP RIP .ntf file  

Go to the Sub-images tab.  
Click on the Multi checkbox.   
 

On my computer it took 2 minutes before I regained control of the File Chooser.   
Once you can, click OK to display the image.  
On my computer it took 1.5 minutes until the image displayed (at 1:1)  

IM-45773 SNIP NITF: 26s to change 

a band 

ERDAS IMAGINE 2018 Update 2 

Start ERDAS IMAGINE  
Click the File icon on the Quick Access Toolbar.  
Select the SNIP RIP .ntf file  

Go to the Sub-images tab.  
Click on the Multi checkbox.   
 

Once the image is displayed go to the Multispectral tab and select a different band 
for the Green color gun.  
On my system it took 26s for the new band to display.  

IM-45771 SNIP NITF: 2 minutes for 
File Chooser Sub-image 

tab to respond 

ERDAS IMAGINE 2018 Update 2 
Start ERDAS IMAGINE  

Click the File icon on the Quick Access Toolbar.  
Select the SNIP RIP.ntf file  
Go to the Sub-images tab.  

Click on the Multi checkbox.   
On my computer it took 2 minutes before I regained control of the File Chooser.   

IM-45777 SNIP NITF: 5 minutes to 
open ImageInfo 

ERDAS IMAGINE 2018 Update 2 
Start ERDAS IMAGINE  

Click the File icon on the Quick Access Toolbar.  
Select the SNIP RIP.ntf file  
Go to the Sub-images tab.  

Click on the Multi checkbox.   
On my computer it took 2 minutes before I regained control of the File Chooser.   
Once you can, click OK to display the image.  

On my computer it took 1.5 minutes until the image displayed (at 1:1)  
Once the image is displayed click the ImageInfo button.  
On my system it took 5 minutes and 30s for ImageInfo to come up and populate 

with information (for one band).  
Each time you change band it takes another 5 minutes.  

IM-49812 Chipping errors likely 
caused by delayed 
TRE/DES parsing 

In ERDAS IMAGINE 2018 Update 2 it was discovered that NITF chipping of 
various classified data was erroring out. This same behavior did not occur with 
earlier versions. It also did not occur when the DPM was uninstalled. [~bshelley] 

traced this down in the debugger to the presence of TRE/DES in the data that had 
delayed parsing implemented in the DPM for Update. 
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ERDAS IMAGINE Installation 

Issue ID Summary – ERDAS 

IMAGINE Installation 

Description / How to Reproduce 

IM-48920 ArcGIS Geodatabase 

Compatibility Table in OLH 
should be updated with 
10.6 and 10.6.1 

ArcGIS Geodatabase Compatibility Table in OLH should be updated with 10.6 and 

10.6.1 (supported versions)  
 
The table shows support till 10.5.1  

IM-46782 Borrowing XML does not 

include IMAGINE SAR 
Feature 

The XML file that controls the dependencies for Borrowing does not seem to include the 

IMAGINE SAR Feature module:  
 
"C:\ProgramData\Intergraph\Licensing\Borrowing\IMAGINE2018.xml" 

IM-43159 Undesirable auto CSM 
configuration behavior 

Observed in ERDAS IMAGINE 2018.  
The utility configure_all.exe now also automatically configures several CSMs delivered 

with the software (for 32 bit SICD,SIDD,VM sensor models, for 64 bit SICD,SIDD 
sensor models).  This behavior is undesirable for the following reasons:  
 

(1) If CSMs were already configured by the user, most likely they are in a different 
location than the "Imagine native" CSMs.  When both are in place, get a Warning 
window complaining that the "Data directory for CSMs" cannot be set to two locations.  

(2) ERDAS IMAGINE 2018 displays a Message window recommending that 32 and 64 
bit CSM configurations be the same.  But this auto CSM configuration does not do this 
(the VM sensor model is only configured in 32 bit).  

(3) If the user had already configured SICD and SIDD sensor models, their 
configuration is overwritten by the "native CSMs".   

IM-43327 Unnecessary install 
directories 

For some reason there are several new directories included with ERDAS IMAGINE 
2018 that weren't there before (and aren't necessary for the software to run) 

IM-48028 The following files don't 
have a valid signature 

The following files that don't have a valid signature,  
* hdf.dll  

* mfhdf.dll  

IM-37464 SIX CSM is not 
automatically configured 
on startup 

SIX CSM is not automatically configured on installation.  

IM-49536 Setup-Manager GUI is 
messed up on my Virtual 

Box with German OS 

With eRDAS IMAIGNE 2018 onwards the Setup Manager (installer) the GUI is messed 
up on machine with a German OS.  It seems to have some (unexpected, undesired) 

links to the right of the tree view where you select the product that are not there on a 
system with English OS. 

 

 

ERDAS ER Mapper 

Issue ID Summary –ERDAS ER 
Mapper 

Description / How to Reproduce 

IM-40262 When Big ERS files are 
compressed in ER 
Mapper into ECW v3, it 

outputs into a completely 
different and bad looking 
image 

Problem replicated with big ERS files, including that of the customer. ER Mapper is 
actually compressing the big ERS file with an extremely high compression ratio. Actual 
Compression ratio more than 500, even if the target compression ratio was just 2 or 3. 

  
When compressing the ERS file into JPEG 2000 format, the problem does not 
happen. Also, when using ERDAS IMAGINE ECW Exporter, that problem does not 

happen for ECW v3. Therefore, the problem seems to be only in ER Mapper ECWv3 
exporter.  
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IM-45954 Execution of creating 
rotated tiff file is 
terminated 

ERDAS ER Mapper 2018  
Go to Toolbars > Common Functions > Ortho and Geocoding Wizard.  
Input file: -Copy file to a new 

location:...\examples\ermapper\applications\airphoto\1_geocoding\ 
San_Diego_Airphoto_34_rectified.ers and San_Diego_Airphoto_34_rectified.  
Geocoding type: Rotation  

Go to Rotation Setup tab, Rotation angle: 45  
Go to Rectify Tab specify output file and write to tif. and select Save file and Start 
Rectification.  

Observe process is terminated, whereas execution is successful for .ers, ECW 

IM-48647 Regions to Vectors and 
Vectors to Regions 
Conversion commands 

Help are pointing to 
Raster to Vector 
conversion Help page 

1) Launch ER Mapper > Toolbars > Classification Toolbar  
2) Launch Regions to Vector conversion / Vector to Regions conversion command  
3) Click on Help button  

Observe that it navigates to Raster to Vector conversion help page  

 

 

PRO600 

Issue ID Summary – PRO600 Description / How to Reproduce 

IM-46078 CALSPOT not working on 
PRO600 2018 Installation 

The collect calspot command does not seem to work, and the PRO600 Library settings 
seem to match the help file for calspot. 

IM-46058 PRO600 viewplex fails to 
load JPG images 

* Open a specific blockfile and attach the JPG images associated with it.  
* Launch Terrain Editor and load the image pair in it.  
* Notice that the image pair is displayed fine.  

* Close Terrain Editor and launch PRO600.  
* After the viewplex is launched, try to load the image pair in the viewplex.  
 

Notice that an error pops up and the image pair fails to load. The same images work 
fine if converted to img. JPG images were able to load in the PRO600 viewplex fine with 
ERDAS IMAGINE 2013. 

IM-45842 PRODTM hangs for a very 

long time while trying to 
measure masspoint 
manually 

In PRO600, while trying to measure the points (mass points) in a grid in PRODTM, 

using measure tool, PRO600 / PRODTM hangs for a very long time. 
While working with the customer data, discovered: 
If import more than 20,000 points (grid 20X20 meter) from the DEM file (IMG format), 

the PRO600 hangs. 
For the same data, created a less dense grid (100X100 meter) where less than 5000 
points are imported, now the PRO600 / PRODTM works fine. 
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Stereo Analyst for ERDAS IMAGINE 

Issue ID Summary – Stereo 

Analyst 

Description / How to Reproduce 

Various Various issues for Stereo 

Analyst for ERDAS 
IMAGINE 

Numerous issues have been addressed for the Stereo Analyst for ERDAS IMAGINE 

product (part of the IMAGINE Expansion Pack module) including the following 
problems/fixes: 
 

• Added a new escape event so that parallel lines get stopped (when you press 
escape) 

• Added escape to save/close buttons (This gets rid of the empty place holders 
- infinity points) 

• Add a new check for parts (faces) that are elements attached to other 
elements, check if these are empty 

• Stops crash when using parallel line then quitting. 

• Clicking quickly on the start button should not cause two errors to pop-up 

• After save as, if failure, the user can repair errors 

• Spelling in warning dialogue for large memory use fixed. 

• Add Element should no longer create zero points 

• Changed precision in vertices editor (to 6 decimal points) 

• Export features fixed 

• Added extra verification checks on save to make sure points have at least 1 
point, lines have at least 2 and polygons have 3 or more points.  

• Restart application when closing all layers to ensure all memory is reset.  

• Label Added for version number 

• Set read only flag when reading TIL files 

• When escaping  the second point of a parallel line, remove all vestiges of the 
line and set the measured width to 0 

• After escaping or changing feature after using parallel tool, remove the entry 
in the table  

• If a user deletes the same face (attached element) twice, the software would 
crash 

• Fixed drop to ground (check for NULL pointer failing) 

• Check parts (tiles) of the file are not only there but can be opened  

• Auto-clean for projects 

• Remove "Infinity Point" generation when user selects to add element, but 
then does NOT add an element - i.e. escapes or chooses another feature 

• Added new controls for the feature attributes (add standard attributes if 
preference "Add standard attributes if missing" is turned on) 

• If attributes are added by the system, the user is informed 

• Cleaned up feature import dialogue 

• Cut is properly added to the undo stack 

• Moved the check for existing to the first thing done (can’t check earlier) 

• Reversed the order of deletion so that multiple errors within the same feature 
can be autocleaned 

• Always clean empty faces (elements) that cannot be deleted from the 
interface 

• Autoclean added better messages for when an error occurs on save 

• Autoclean working consistently 

• Extra parallel line no longer created when 3D snap is on and parallel lines are 
being drawn. 3D snap is tested on the first point (not the measured point) if 

no snap, then behave like normal  

• Redo multiple deletes, no longer crashes 

• Added flags to allow reads while reading (image format inside another format)  

• Changing a vertex enables the save button 

• Enabled delete from table (Right click in ID column delete is enabled) 

• Header drawn correctly when no shapefile available 

• Modified error message for missing vertices 

• Added check for Duplicate Attributes (It was just adding 1 to the last in the 
list) 

• Select does not cancel current edits 
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  • Spelling mistake 

• Added check for calculated box. If out of bounds don't use 

• Fix Undo if no undo to undo 

• Removed Error message when final shape check is done (and fails), only the 
warning message is now returned, telling the user how to correct. 

• Fix vertex removal issue 

• Fix selection of faces 

• Fix undo selected face 

• Notify user of deletion to the face / element (automated) 

• Update error messages when checking for errors in digitizing 

• Update (and create) function to remove orphan parts of elements 

• Fix issue when the first part of a segment is removed 

• Slight modification to write/check function so that the check is completed on 
all appropriate layers before any writing 

• Cone fix 

• New preference for Minimum number of vertices (PolyLines and Polygon) 

• Implementation of delay (configurable) before saving 

• Secondary save on save error. (If an error occur when a tempv file is 
encountered, attempt the save again) 

• Crash on Save fixed (if tempv file error created and user continues) 

• Surface layer feature hang error (again when tempv file has been 
encountered) 

• Bug when selecting a feature, then dropping the feature to ground and 
splitting an element group and adding a part/face all at the same time. 

• Parrallel Line fix 

• New Preference to save all layers or just changed layers 

• Only save feature layers that have changed 

• If a rename fails (tempv, temp) when saving shapefile retry up to 3 times with 
a delay (300ms) between 
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Contact Us 
 

 

https://go.hexagongeospatial.com/contact-us-today      

 

 

 

 

 

 

 

 

 
 
 
 
About Hexagon 
Hexagon is a global leader in sensor, software and autonomous solutions. We are putting data to work to 
boost efficiency, productivity, and quality across industrial, manufacturing, infrastructure, safety, and mobility 
applications.  

Our technologies are shaping urban and production ecosystems to become increasingly connected and 
autonomous — ensuring a scalable, sustainable future.  

Hexagon’s Geospatial division creates solutions that deliver a 5D smart digital reality with insight into what 
was, what is, what could be, what should be, and ultimately, what will be. 

Hexagon (Nasdaq Stockholm: HEXA B) has approximately 20,000 employees in 50 countries and net sales of 
approximately 4.3bn USD. Learn more at hexagon.com and follow us @HexagonAB. 
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Copyright  
© 2019 Hexagon AB and/or its subsidiaries and affiliates. All rights reserved. Hexagon has registered 
trademarks in many countries throughout the world. Visit the Trademarks Page 
http://www.hexagongeospatial.com/legal/trademarks for information about the countries in which the 
trademarks are registered. See Product Page and Acknowledgments for more information. 

Product Documentation Terms of Use 
PLEASE READ THESE TERMS CAREFULLY BEFORE USING HEXAGON GEOSPATIAL’S 
DOCUMENTATION ("DOCUMENT"). USE OF THIS DOCUMENT INDICATES ACCEPTANCE OF THIS 
AGREEMENT WITHOUT MODIFICATION. IF YOU DO NOT AGREE TO THE TERMS HEREOF ("TERMS"), 
DO NOT USE THIS DOCUMENT. 

Use Of This Document 
All materials in this Document are copyrighted and any unauthorized use may violate worldwide copyright, 
trademark, and other laws. Subject to the terms of this Agreement, Hexagon Geospatial (a Division of 
Intergraph Corporation) and Intergraph’s subsidiaries ("Intergraph") hereby authorize you to reproduce this 
Document solely for your personal, non-commercial use. In consideration of this authorization, you agree to 
retain all copyright and other proprietary notices contained therein. You may not modify the Materials in any 
way or reproduce or publicly display, perform, or distribute or otherwise use them for any public or commercial 
purpose, except as specifically authorized in a separate agreement with Hexagon Geospatial.  

The foregoing authorization specifically excludes content or material bearing a copyright notice or attribution of 
rights of a third party. Except as expressly provided above, nothing contained herein shall be construed as 
conferring by implication, estoppel or otherwise any license or right under any copyright, patent or trademark 
of Hexagon Geospatial or Intergraph or any third party. 

If you breach any of these Terms, your authorization to use this Document automatically terminates. Upon 
termination, you will immediately destroy any downloaded or printed Materials in your possession or control. 

Disclaimers 
ALL MATERIALS SUPPLIED HEREUNDER ARE PROVIDED "AS IS", WITHOUT WARRANTY OF ANY 
KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, ANY IMPLIED 
WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, OR NON-
INFRINGEMENT. Hexagon Geospatial does not warrant that the content of this Document will be error-free, 
that defects will be corrected, or that any Hexagon Geospatial Website or the services that make Materials 
available are free of viruses or other harmful components. 

Hexagon Geospatial does not warrant the accuracy and completeness of this Document. Hexagon Geospatial 
may make changes to this Document at any time without notice. 

Limitation Of Liability 
IN NO EVENT SHALL HEXAGON GEOSPATIAL BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, 
SPECIAL OR CONSEQUENTIAL DAMAGES, OR DAMAGES FOR LOSS OF PROFITS, REVENUE, DATA 
OR USE, INCURRED BY YOU OR ANY THIRD PARTY, WHETHER IN AN ACTION IN CONTRACT OR 
TORT, ARISING FROM YOUR ACCESS TO, OR USE OF, THIS DOCUMENT. 

Indemnification 
You agree to defend, indemnify, and hold harmless Hexagon Geospatial, its officers, directors, employees, 
and agents from and against any and all claims, liabilities, damages, losses or expense, including reasonable 
attorneys' fees and costs, arising out of or in any way connected with your access to or use of this Document. 
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Use Of Software 
Use of software described in this Document is subject to the terms of the end user license agreement that 
accompanies the software, if any. You may not download or install any software that is accompanied by or 
includes an end user license agreement unless you have read and accepted the terms of such license 
agreement. Any such software is the copyrighted work of Hexagon Geospatial, Intergraph or its licensors. 
Portions of the user interface copyright 2012- Telerik AD. 

Links To Third Party Websites 
This Document may provide links to third party websites for your convenience and information. Third party 
websites will be governed by their own terms and conditions. Hexagon Geospatial does not endorse 
companies or products to which it links. 

Third party websites are owned and operated by independent parties over which Hexagon Geospatial has no 
control. Hexagon Geospatial shall not have any liability resulting from your use of the third party website. Any 
link you make to or from the third party website will be at your own risk and any information you share with the 
third party website will be subject to the terms of the third party website, including those relating to 
confidentiality, data privacy, and security. 

Trademarks 
The trademarks, logos and service marks ("Marks") displayed in this Document are the property of Hexagon 
Geospatial, Intergraph or other third parties. Users are not permitted to use Marks without the prior written 
consent of Hexagon Geospatial, Intergraph or the third party that owns the Mark. "Intergraph" is a registered 
trademark of Intergraph Corporation in the United States and in other countries. Other brands and product 
names are trademarks of their respective owners. 

Find additional trademark information https://www.hexagongeospatial.com/legal/trademarks. 

Procedure For Making Claims Of Copyright Infringement 
Notifications of claimed copyright infringement should be sent to Hexagon Geospatial by mail at the following 
address: Intergraph Corporation, Attn: Intergraph Legal Department, P.O. Box 240000, Huntsville, Alabama 
35824. 

US Government Restricted Right 
Materials are provided with "RESTRICTED RIGHTS." Use, duplication, or disclosure of Materials by the U.S. 
Government is subject to restrictions as set forth in FAR 52.227-14 and DFARS 252.227-7013 et seq. or 
successor provisions thereto. Use of Materials by the Government constitutes acknowledgment of Hexagon 
Geospatial or Intergraph’s proprietary rights therein. 

International Use 
You may not use or export Materials in violation of U.S. export laws and regulations. Hexagon Geospatial 
makes no representation that Materials are appropriate or available for use in every country, and access to 
them from territories where their content is illegal is prohibited. 

Hexagon Geospatial provides access to Hexagon Geospatial international data and, therefore, may contain 
references or cross references to Hexagon Geospatial products, programs and services that are not 
announced in your country. These references do not imply that Hexagon Geospatial intends to announce such 
products, programs or services in your country. 

The Materials are subject to U.S. export control and economic sanctions laws and regulations and you agree 
to comply strictly with all such laws and regulations. In addition, you represent and warrant that you are not a 
national of, or otherwise located within, a country subject to U.S. economic sanctions (including without 
limitation Iran, Syria, Sudan, Cuba, and North Korea) and that you are not otherwise prohibited from receiving 
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or accessing the Materials under U.S. export control and economic sanctions laws and regulations. Hexagon 
Geospatial makes no representation that the Materials are appropriate or available for use in every country, 
and access to them from territories where their content is illegal is prohibited. All rights to use the Materials are 
granted on condition that such rights are forfeited if you fail to comply with the terms of this agreement. 

Revisions 
Hexagon Geospatial reserves the right to revise these Terms at any time. You are responsible for regularly 
reviewing these Terms. Your continued use of this Document after the effective date of such changes 
constitutes your acceptance of and agreement to such changes. 

Applicable Law 
This Document is created and controlled by Hexagon Geospatial in the State of Alabama. As such, the laws of 
the State of Alabama will govern these Terms, without giving effect to any principles of conflicts of law. You 
hereby irrevocably and unconditionally consent to submit to the exclusive jurisdiction of the United States 
District Court for the Northern District of Alabama, Northeastern Division, or the Circuit Court for Madison 
County, Alabama for any litigation arising out of or relating to use of this Document (and agree not to 
commence any litigation relating thereto except in such courts), waive any objection to the laying of venue of 
any such litigation in such Courts and agree not to plead or claim in any such Courts that such litigation 
brought therein has been brought in an inconvenient forum. Some jurisdictions do not allow the exclusions or 
limitations set forth in these Terms. Such exclusions or limitations shall apply in all jurisdictions to the 
maximum extent allowed by applicable law. 

Questions 
Contact us with any questions regarding these Terms. 

https://www.hexagongeospatial.com/about-us/our-company/contact-us

